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Abstract 

Currently large amounts of environmental data are delivered through “GEONETCast-EUMETCast”. 
ILWIS plug-ins are developed to import various data types delivered via these telecommunication 
based systems. The generic RS and GIS capability offered by ILWIS can be used for further 
processing of the data.  
 
These systems disseminate real and near real-time environmental data which can be received using 
a low cost ground receiving station. On the other hand, various environmental data resources, 
especially time series of data, are currently available through the internet. The “In Situ and Online 
Data Toolbox” (ISOD) is developed to easily ingest these data sources. The data supplements the 
information delivered through the data dissemination systems mentioned above, but requires internet 
connectivity.  
 
The toolbox is identical in design as compared to the other toolbox plug-ins, like the GEONETCast 
Toolbox. This document is proving a description where to download all the freeware utilities, how to 
install and configure them. The ISOD Toolbox developed is an open utility. It can be easily modified 
and tuned to fit the specific user needs without programming skills. Next to this description also an 
overview is presented on the various data resources that can be automatically retrieved and 
processed. Finally the document provides hands-on exercises how to use the utilities offered. The 
exercises provided are focusing on near real-time climatological in situ observations, gauge and 
satellite derived precipitation products, weather and pressure forecasts, potential evapotranspiration, 
normalized difference vegetation indices, ocean and elevation information. 
 
The utilities provided are extensively tested using various operating systems, such as Windows 
Vista, XP (various service packages) and Windows-7 and have found to be performing in a stable 
manner. The toolbox currently does not work under LINUX. In case unexpected behaviour or bugs 
are observed, additions to the functionality are required or if you have developed new utilities which 
you want to share, please contact the EO Community Contact (http://52north.org/communities/earth-
observation/ community-contact).  
 
 
                                                                                                                                            
Ben Maathuis and Chris Mannaerts 
Department of Water Resources 
Faculty ITC – University of Twente 
Enschede, The Netherlands 
October  2012 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



2 

 

LIST OF ACRONYMS AND ABBREVIATIONS 

52North--------------------- 
ARC------------------------- 
ASTER--------------------- 
AVHRR--------------------- 
CMORPH------------------ 
CPC------------------------- 
EO--------------------------- 

52°North Initiative for Geospatial Open Source Software 
Africa Rainfall estimate Climatology 
Advanced Spaceborne Thermal Emission and Reflection Radiometer 
Advanced Very High Resolution Radiometer 
Climate Prediction Centre Morphing Technique for rainfall estimation 
Climate Prediction Centre 
Earth Observation

ECMWF-------------------- European Centre for Medium-Range Weather Forecast 
eMODIS-------------------- Expedited MODIS 
ESA------------------------- 
EUMETCast--------------- 
EUMETSAT--------------- 
FTP------------------------- 

European Space Agency 
Telecommunication based data dissemination system 
European Organisation for the Exploitation of Meteorological Satellites 
File Transfer Protocol

FEWSNET---------------- United States Agency for International Development (USAID) Famine Early 
Warning System 

GDAL----------------------- Geospatial Data Abstraction Library
GDEM---------------------- Global Digital Elevation Model 
GEONETCast------------- Telecommunication based data dissemination system 
GMTED-------------------- Global Multi-resolution Terrain Elevation Data
GSOD---------------------- Global Summary of Day Data 
GTS------------------------ Global Telecommunication System 
ILWIS----------------------- Integrated Land and Water Information System (GIS-RS software) 
ISOD Toolbox------------- 
IrfanView------------------- 

In Situ and Online Data Toolbox 
Software tool for visualization of pictures 

ITC-------------------------- Faculty of Geo-Information Science and Earth Observation, University of 
Twente, the Netherlands 

ITF or ITCZ--------------- Intertropical Convergence Zone 
ISD-------------------------- Integrated Surface Data 
MEaSure------------------- NASA project to develop Vegetation Phenology and Vegetation Index 

Products from Multiple Long Term Satellite Data Records 
MODIS--------------------- Moderate Resolution Imaging Spectrometer 
MPE------------------------ Multi sensor Precipitation Estimate 
NDVI------------------------ Normalized Difference Vegetation Index 
NASA----------------------- National Aeronautics and Space Administration 
NOAA----------------------- National Oceanic and Atmospheric Administration 
OS--------------------------- Open Source 
PET------------------------- Potential EvapoTranspiration 
QMORPH------------------ Identical to CMORPH but without Infra-red propagation rainfall etimate 
RFE------------------------- Rainfall Estimate 
RFS------------------------- Rainfall Satellite for Latin America 
SPOT----------------------- Système Probatoire d’Observation de la Terre ou Satellite Pour 

l’Observation de la Terre 
SRTM---------------------- Shuttle Radar Topographic Mission 
SST------------------------- Sea Surface Temperature 
TAF------------------------- Terminal Aerodrome Forecast 
TAMSAT------------------- 

 
USAF----------------------- 

Tropical Applications of Meteorology using Satellite data and ground-based 
observations 
United States Air Force 

TRMM--------------------- Tropical Rainfall Monitoring Mission 
UTC------------------------ Universal Time Coordinated 
XML------------------------- Extensible Markup Language 
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RELEASE NOTES 

Following comments have to be taken into consideration with respect to the release of this ISOD 
Toolbox, XML version 1.1: 
 

1. This is the second release and utmost care was taken to ensure appropriate operation of the 
routines developed but at this stage some defects might still be included and should be 
reported to the corresponding author to be included in a new release; 

2. For the release of this toolbox version all data sources used have been checked. For some 
data sources the data format or naming conventions have changed. It was also noted some 
data has been re-processed. Furthermore Internet has a transient nature; some links might 
not be active after some time. If any of such a problems are encountered please report these 
to the corresponding author; 

3. No liability can be accepted for use of the ISOD Toolbox by the toolbox developers; 
4. When using the ISOD Toolbox you agree and comply with the conditions of the software 

utilities used as well as the terms and conditions stipulated by various online data providers 
for the use or references to the source of the data. 
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1. GENERAL INSTALLATION AND CONFIGURATION INSTRUCTIONS 

1.1 INTRODUCTION 
Follow the instructions provided below to install ILWIS Version 3.7.2, the ISOD Toolbox and a number 
of other free software utilities, in order to work with the data provided via open internet resources. 
Read the instructions provided below carefully and proceed with the installation of the various utilities. 
In case you want to use the ISOD Toolbox, be aware that at this moment it is not running under 
LINUX-Ubuntu. Furthermore this ISOD Toolbox version is not downwards compatible; you need to use 
at least ILWIS Version 3.7.2. 

1.2 DOWNLOAD ILWIS 

Available from:  http://52north.org/ 
 
From this location select the navigation tab: “Downloads” or directly select 
“http://52North.org/downloads/ILWIS”. Select the latest (multiple file) ILWIS372 version (“ILWIS 
3.07.02”) and download the ZIP file(s), save the file(s) in a temporary directory on your hard disk. 
Unzip the file and run the ILWIS setup. When you intend to use the ISOD Toolbox do not install 
ILWIS372 under the default installation directory “C:\Program Files” as this might cause 
problems with respect to administration rights (especially under Windows 7) when creating temporary 
files and because the toolbox is utilizing DOS batch routines, which can be affected by the space in 
the directory file name “Program Files”. Select as your installation “drive:\directory” a location where 
you have the proper administrative rights (e.g. “D:\ILWIS372”). In the “ILWIS372” directory a shortcut 
to the “ILWIS.exe” can be created, you can copy this shortcut to the desktop of your system.  
 
Please take into consideration, straight from the start, the following golden rules when using 
ILWIS: 

 Don’t use spaces in file names, instead use underscores; 
 Do not only use numbers as file names; 
 Do not work in multiple output directories; 
 Start ILWIS, navigate to your working directory and close ILWIS. Open ILWIS again to ensure 

that your current working directory is also the actual ILWIS working directory. 

1.3 DOWNLOAD THE ISOD TOOLBOX 

Available from:  http://52north.org/ 
 
To download the ISOD Toolbox from the 52North website: Select from the 52north.org website the 
navigation tab: “Earth Observation”. Additional information is provided over there as well as the link to 
the download area. You can also directly download the Toolbox from 
http://52north.org/downloads/earth-observation, select “ISOD”. Download the Zip file: “52n-eo-isod-
toolbox-1.1” available over there and store it in a temporary directory. Eventually download other 
resources provided over there. 
 
After the download is completed, copy this ZIP file in the ILWIS sub-directory “\Extensions”. There is 
no need to unzip the file! ILWIS automatically detects the ZIP file in this directory then unzips the file 
and installs the plug-in when a new instance of ILWIS is started. Afterwards the ZIP file is deleted in 
this “\Extensions” sub-directory!  
 
Start ILWIS and in the Operation-Tree of ILWIS the “ISOD” tab will appear (see also figure 1.1). 
Double click the “ISOD” tab and the subsequent “Toolbox” tab and various (sub) menus are now at 
your disposal. These options can be used to import open internet environmental data sets. Keep 
checking the “Earth Observation” community web pages (http://52north.org/ communities/earth-
observation/) for new (toolbox) developments. Modifications and added functionality for the ISOD 
Toolbox are made available on these websites on an ad hoc basis, so check if you are working with 
the latest version. The XML configuration number, currently 1.1, is given on the lower left hand portion 
of the ISOD Toolbox opening screen. 
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Figure 1.1: The ISOD main and sub menu structure under ILWIS372 

 
 
Close ILWIS as you might need to install additional utilities. Check if you have already installed 
IrfanView. If this is not case use the link below and follow the additional installation instructions. 

1.4 DOWNLOAD IRFANVIEW 

Available from:  http://www.irfanview.com/ 
 
For some data visualizations and animation that do not require import into an ILWIS data format, use 
is made of IrfanView. Download the setup executable and save it in a temporary directory on your 
hard disk. 
 
After the download has been completed run the setup, there is no need to create shortcuts, use the 
option: “For all users” and select the default Installation folder. Click “Next” three times, just use the 
default settings, “Don’t install Google Desktop Search”, click “Next” two times and after the installation 
has been completed, press “Done”.  
 
An instance of IrfanView can be started to check if the installation has been successful, the program 
can be stopped. 

1.5 DOWNLOAD PANOPLY 

Available from: http://www.giss.nasa.gov/tools/panoply/ 
 
Currently data retrieved from ECMWF are visualized using Panoply, developed by Robert B. 
Schmunk, NASA Goddard Institute for Space Studies. The Panoply package for Windows comes as a 
zipped archive. Manually extract this archive in the ILWIS sub-directory “\Extensions\ISOD-
Toolbox\util\Panoply”. This sub-directory, after uncompression, should include the following items: 
Panoply.exe (application), application code files in a folder called "jars", colour tables in a folder called 
"colorbars", continent masks and outlines in a folder called "overlays". You can check to run Panoply 
by double-clicking on the Panoply.exe application. 
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1.6 CONCLUDING REMARKS 

With ILWIS, the ISOD Toolbox plug-in and the other necessary utility-software installed you still need 
to continue with the ISOD Toolbox configuration settings which are further described in the next 
chapter, next to additional information with regard to the overall toolbox architecture. 
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2. OVERVIEW OF THE ISOD TOOLBOX ARCHITECTURE 

2.1 INTRODUCTION 

The ISOD Toolbox Config XML version 1.1 allows import of various web based environmental data 
resources through a Graphical User Interface (GUI). Here the toolbox architecture is described into 
more detail. Once the toolbox is installed and ILWIS is newly started the “ISOD Toolbox” should 
appear as a menu item under the ILWIS Operation Tree (see figure 2.1). 
 

Figure 2.1: The ISOD Toolbox plug-in Graphical User Interface 

 

2.2 STRUCTURE OF THE ISOD TOOLBOX 

To operate the ISOD toolbox, the Zip file “52n-eo-isod-toolbox-1.1” is copied under the ILWIS sub-
directory “\Extensions”. Once a new event of ILWIS372 is started this ZIP file is extracted and the 
content is stored in the sub-directory “\ISOD-Toolbox” within the same “\Extensions” sub-directory. 
Within the “ISOD-Toolbox” sub-directory a number of other sub-directories appear (see figure 2.2). 
 
Figure 2.2: Toolbox sub-directory structure 

 
 

The folder “\GDAL” (Geospatial Data Abstraction 
Library) contains a translator library for raster 
geospatial data formats that is released under an 
X/MIT style Open Source license by the Open 
Source Geospatial Foundation (http://www.gdal. 
org). 
 
The folder “\System” is storing the ILWIS service 
objects. Service objects are used by data 
objects; they contain accessories required by 
data objects besides the data itself. Upon 
installation of the toolbox, these objects are 
copied to the main ILWIS directory \System. 
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The folder “\Toolbox_batchroutines” provides the batch files that are used to execute most of the 
actual operations. These files can be opened and modified using a text editor. Further information is 
provided in chapter 2.6. Before you modify a routine, first make a backup! 
 
The folder “\Toolbox_startscript” contains a number of sub-directories which contain the ILWIS scripts. 
Upon selection of an import routine, from the ISOD Toolbox User Interface a script is called and this 
script subsequently calls a batch file which executes the operation. The scripts can also be opened 
and modified using ILWIS. Further information is provided in chapter 2.5. 
 
In the root of the “\Util” folder ILWIS service objects are stored, like lookup tables, georeferences, 
domains, etc. Furthermore a number of executables are stored here that are used by various toolbox 
batch routines, such as the “7z” executable. The sub-directory “\Maps” is containing a segment-
polygon file of all countries and for Africa. The sub-directory “\wget” is storing the utility used to extract 
the selected data from the internet http or ftp location. The sub-directory “\metadata” contains a 
number of files that provide ancillary information describing the nature of the data to be retrieved. A 
sub-directory “\Panoply” should be created by the user and the “Panoply” utility should be stored there 
(see also chapter 1.5). 
 
The file “config.xml” contains the ISOD Toolbox GUI menu structure. This file can be edited using a 
text editor. In case the user wants to add new routines, this XML file can be adapted and modified. 
The resulting menu will be adapted accordingly when a new instance of the Toolbox is started. This 
allows users that do not have programming experiences to adapt the toolbox to their own preferences. 
A more detailed description is provided below in chapter 2.3. 
 
The file “isod.ini” contains the settings of the input and output directories for each “folderid” that is 
defined in the “Config.xml”. This file is storing the settings as defined from the Toolbox menu options 
“Configuration” >> “Folders”. Further information on the folder settings is provided in chapter 2.4.  
 
The file “EO-Toolbox.dll” contains the layout of the User Interface of the ISOD Toolbox and generates 
the full ILWIS command string that executes the script, batch file, defines and passes the parameters 
that are used, like the time stamp, input drive, input directory, output drive, output directory, ILWIS 
directory, etc. Up to 9 parameters are used to execute a Toolbox operation. 
 
The file “EO-Toolbox.dll.manifest” is used by the operating system for certification of the appropriate 
DLL. 
 
NOTE: As from ILWIS38 a new version of the “EO-Toolbox.dll” has to be used. This file can be 
downloaded from the “Earth Observation Downloads Area” (http://52north.org/communities/earth-
observation/). When using ILWIS38, copy this file into the ILWIS directory “\Extensions\ISOD-
Toolbox”. Eventually overwrite the existing “EO-Toolbox.dll”. The ISOD Toolbox plug-in should now 
appear in the Operation-Tree, identical to figure 2.1 when activating ILWIS38.  

2.3 STRUCTURE OF THE CONFIG XML 

One of the main criteria during the development of this utility was to make the toolbox as open as 
possible, allowing users with no programming experiences to make modifications. As indicated before, 
all scripts and batch routines used can be adapted by the user. Next to this, the user can also modify 
the menu of the Toolbox GUI. The file that generates the user interface, “Config.xml”, can be opened 
using a text editor. 
 
The structure of the file is kept as simple as possible. The “Level” is defining the main (Level1) and 
sub menu structure (Level2 – Level ”N”). For the “Level value=” a menu name can be defined. Within 
a certain Level a “Product value=” can be specified, which will generate the name of the respective 
(sub) menu. 
 
The string starting with “Product value=” contains mostly a number of other items, like “script”, 
“format”, “type”, “folderid” and “comment”. 
 

 Script: The item script defines the sub-directory were the respective ILWIS script is located 
and the name of the script that should be executed; 
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 Format: The text string that can be entered here will appear in the popup window when 
importing a certain image or product. It is used to ensure that e.g. the appropriate “time 
stamp” is entered on the user interface (see the “Date” on figure 2.3). For the various images 
and products these can have different formats, in the example of figure 2.3 the “Date” stamp 
expected should have the format “yyyymm” (yyyy=year, mm=month). Also jjj=Julian day, 
dek=Dekade are used, e.g. ”yyyymmdekdek”; 

 Type: This is the only part of the toolbox that does not allow user modification without 
programming experiences. Various forms, that generate the pop-up windows are available 
within the “EO-ToolboxUI.dll” and are called by their specific names given. These forms 
generate the appearance of the popup windows when importing a specific product. The popup 
menu that is given in figure 2.3 is generated from a “type” called: “ymdhmo”; 

 Folderid: This item generates a folder item in the “isod.ini” file. From the main Toolbox menu, 
“Configuration” and “Folders” option, this Folder item is now available and can now be further 
specified by defining the appropriate input and output directories.  

 Comment: Additional information (one line of text) can be provided in the popup menu to notify 
the user on any specific information that might be relevant. In figure 2.3 a comment string is 
added showing the “Date” format expected (m=month) and the location the data is extracted 
from.  

 
Figure 2.3: Popup menu for import TAMSAT rainfall products 

 
 
Other syntax used in the config.xml is: 

< Start of a new line 
/> End of a line 
<Level… Start of a new level 
</Level”n”> End of level “n” 

 
Note that all the text should be entered between quotation marks “”. 
 
The first few lines of the config.xml are: 
1: < ISOD > 
2: <Version id="1.1" finder="false"/> 
3: <UIInfo icon="earth" menu="ISOD..Toolbox" title="In Situ and Online Data Toolbox"/> 
4: <Path value="Extensions\ISOD-Toolbox" inifile="isod.ini"/> 
 
Line 1 provides the link to the plug-in and the menu name, note that this is also the last line of the 
XML. Line 2 provides the opportunity to indicate a version number, useful if modifications are done to 
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the original XML. The version number is also shown in the main ISOD Toolbox menu, in the lower left 
hand corner. The “Finder” is a utility under development, allowing a search using keywords.  The 
“UIInfo Icon” in line 3 refers to the toolbox logo used in the ILWIS Operation Tree, the “menu” provides 
the name, the “..” indicates that the menu consists of two levels, and the heading used in the toolbox 
user interface is defined by the “title”. In Line 4 the “path” defines the location of the toolbox in ILWIS 
and the “inifile” here refers to the “isod.ini” file, which provides the links to the input and output 
directories. 
 
After changes are made to the config.xml the file should be saved and a new instance of the Toolbox 
should be started, showing the adaptations. Before modifying the file first make a backup! 

2.4 GENERAL ISOD TOOLBOX CONFIGURATION - FOLDER SETTINGS 

For you to conveniently work with the ISOD Toolbox the local system output (working) directories need 
to be defined. From the main ISOD Toolbox menu, select “Configuration” and the sub-menu “Folders”. 
In figure 2.4 below the output directory for the Global Multi-resolution Terrain Elevation Data 2010 
(GMTED2010) is used as example (“D” is the local system hard disk). If the folders are correctly 
specified the “Save” button should be pressed to store the ‘drive:\folder’ settings.   
 

Figure 2.4: Setting of the output directory structure  

 
 
The “isod.ini” file can also be edited using a text editor to change using the “find and replace” option 
e.g. the drive for all directory entries in the file. Also the full directory settings can be specified, as 
example a “folderid” of “GMTED_DEM” is given. When opening the “isod.ini” file, using a text editor, 
an item “[GMTED_DEM]” is given and the output folder can now be changed by providing the relevant 
directory names, like: 
 
    [GMTED_DEM] 

OutputFolder=D:\working_dir 
 
There is a “Special locations” folder to select the location of an executable. Currently the location of 
“IrfanView” and “i_view32.exe” (or newer version) needs to be specified. This freeware utility is used 
for visualization and animation of pictures that are not transformed into an ILWIS data format. Make 
sure that this folder and executable are always correctly specified. Installation instructions are given in 
chapter 1.4. 
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2.5 STRUCTURE OF THE ISOD TOOLBOX SCRIPTS 

Most of the ILWIS scripts, situated within the sub-directories within the “\Toolbox_startscripts\” 
directory contain a single line having an identical structure. Below an example is given of the 
extraction of the “SRTM Version4 elevation data” script: 
 
!%7\Extensions\ISOD-Toolbox\toolbox_batchroutines\SRTM4_import.bat %1 %2 %3 %4 %5 %6 
%7 %8 
 
The command line starts with: ! This syntax (!) instructs ILWIS to start an external application. The 
application that should be started is situated in “%7\Extensions\ISOD-Toolbox\ toolbox_batchroutines\” 
and calls “SRTM4_import.bat”. This is a DOS batch routine which should be executed. The 
parameters required to execute the batch routine are given as %1 to %8: 
 

%1 Longfilename remark: the lower left corner coordinates for the specific elevation tile 
%2 InputDrive   remark: input data drive, not used here 
%3 InputDir   remark: input data directory, not used here 
%4 OutputDrive  remark: output data drive 
%5 OutputDir   remark: output data directory 
%6 gdalDir   remark: location of GDAL directory within the toolbox 
%7 IlwDir   remark: location of the ILWIS directory 
%8 UtilDir   remark: location of the Util directory within the toolbox 

 
A number of these parameters are generated by the “EO-Toolbox.dll”, such as gdalDir, IlwDir and 
UtilDir as these are fixed locations within the toolbox. Other parameters require user interaction, such 
as longfilename, InputDrive, InputDir, OutputDrive, OutputDir, as these change based on the user 
preferences. These parameters can be interactively provided in the popup menu when importing an 
image or product, see e.g. figure 2.3 above. The “Date” field provides the “Longfilename”, input and 
output drive and directory for the “InputDrive”, “InputDir”, “OutputDrive” and “OutputDir” respectively. 
 
When pressing the “Import” button of the popup menu (see again figure 2.3) an ILWIS command line 
is generated which is executed. Using the script example above for import of an SRTM elevation tile 
for Long=E030 and Lat=S20, the following command line is generated and executed: 
 
!D:\Ilwis372 \Extensions\ISOD-Toolbox\toolbox_batchroutines\SRTM4_import.bat E030S20 x x 
D: working_dir D:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin D:\Ilwis372 D:\Ilwis372 
\Extensions\ISOD-Toolbox\util 
 
The parameters are now defined as follows: 
%1 Longfilename   E030S20 (note that this is a modification of the “Date” stamp) 
%2 InputDrive    x (not used here) 
%3 InputDir    x (not used here) 
%4 OutputDrive   D: 
%5 OutputDir   working_dir  
%6 gdalDir   C:\Ilwis372\Extensions\AMESD-SADC-Toolbox\GDAL\bin 
%7 IlwDir    C:\Ilwis372 
%8 UtilDir    C:\Ilwis372\Extensions\AMESD-SADC-Toolbox\util 
 
Now with all parameters set the batch file “SRTM4_import.bat”, situated in the ILWIS subdirectory 
“\Extensions\ISOD-Toolbox\toolbox_batchroutines\” can be executed. Starting the command with the 
“!”, ILWIS knows it has to execute an external command, given the fact that the extension is “.bat”, the 
Windows operating system knows it has to execute this file using the Windows Command Line 
Processor (CMD.exe). 
 
For a number of visualization and animation routines to view picture products (in png, gif or jpg 
formats) “IrfanView” is used. In these cases an additional parameter is defined as %9, called 
“IrfanViewDir”. This parameter defines the location of the IrfanView directory and executable. It can be 
specified under “Configuration” >> “Folders” and “Special locations” options from the ISOD Toolbox 
User Interface. 
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2.6 STRUCTURE OF THE ISOD TOOLBOX BATCH ROUTINES 

As is the case with the ILWIS scripts, also most of the batch files follow a similar structure. As an 
example a retrieval of the “FEWSNET – eMODIS NDVI for South Africa” import routine is given below. 
The first 9 lines (see line numbers) are giving some general remarks and these are shown in the 
command line window, see figure 2.5. The command “echo.” results in an empty line in the command 
line window, which is used to improve the readability of the text given in the command line window.  
 
From line 10 to line 19 in the batch file the “Date” stamp, here defined as “longfilename” is passed, 
originating from the ILWIS script, to the batch file using the “SET” command. This command displays, 
sets or removes Windows Environment Variables.  
 
When starting this import operation for the Date field the appropriate NDVI map date should be 
entered, here defined as “perperyyyy” (see also line 6 and 7, per = period). Two digits are needed to 
define the period, from 01 up to 72. As the period stamp in the archive for the first 9 periods per year 
only uses one digit (from 1 up to 9), for the periods 01 up to 09 the zero value (0) is removed in lines 
12 to 15 and passed as a parameter called %mnthtif%. For the year only the last two digits are 
retained and passed as %shortfilename3% in lines 16 to 19. The result of this operation is that when 
entering a string like “022012” it is modified into a string “212”, which is needed to correctly recompose 
the filename in the archive (see also line 6).  
 
From lines 20 to 26 the other parameters are passed, originating from the ILWIS script, to the batch 
file. Once all these parameters are known the actual import routine can start. Lines 27 to 29 ensure 
that the application moves to the appropriate output directory. Line 30 displays the selected output 
directory in the command line window (see figure 2.5). The items “echo.” in lines 31 and 32 creates 
two empty lines in the command line window.  
 
Once in the output directory line 33 starts the “Wget” utility which retrieves the requested input data 
from the specified internet location, using the appropriate file name, partially derived from the “Date” 
stamp, note “%mnthtif%%shortfilename3%”. Line 34 sets the display of subsequent messages off. 
 
In line 35 a check is performed if the input file exists, if this file does not exist the batch routine jumps 
to the section starting with “:MESSAGE”. If the input file exists line 36 is displayed in the command line 
window, followed by 2 empty lines and then jumps to the start of the actual import routine, which 
begins at the “:START” section (line 39).  
 
If the input file does not exist (in line 35) the batch routine jumps to line 40 “:MESSAGE”, the section 
below (lines 41 to 46) are displayed, see also figure 2.5. In line 47 a “pause” command is used and the 
user has to press <enter> in order to continue. Once this is done the “GOTO END” command in line 
48 causes the routine to jump to line 60. 
 
If the data is located in the specified input drive-directory, the copied file is unzipped in line 50, 
renamed in line 51 and imported into ILWIS  format in line 52, using GDAL. Once the file is in ILWIS 
format, ILWIS is executed from the command prompt in line 53 and the radiometry of the data is 
changed using an expression: (NDVI_in-100)/100. In line 54 the coordinate system is appended 
(ilwis.exe -C setgrf) to set the georeference of the final NDVI map. Lines 55 – 59 are deleting the files 
that have become obsolete. 
 
Line 60 marks the “:END” section. With or without the required input data line 61 is always executed, 
this line closes instances of ILWIS which have started using this batch routine.  
 
Start of batch file listing: fews_emodis_ndvi_sa.bat 
---------------------------------------------------------------------------------------------------------------------------------------- 
 1: @echo off 
 2: echo Extract FEWS eMODIS NDVI 
 3: echo From 012010 - to 1 month before present 
 4: echo eMODIS 10-day maximum-value composite NDVI images at 250m spatial resolution  
 5: echo Note periods (odd and even periods) 
 6: echo File name format sa3711.zip (sa=south africa, 37=period 37 and 11=year 2011) 
 7: echo Time string entered for example 012010 
 8: echo. 
 9: echo. 
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10: set longfilename=%1 
11: set shortfilename1=%longfilename:~2,4% 
12: set period=%longfilename:~0,2% 
13: set mnthtif=%period% 
14: set deccounter=%mnthtif:~0,1% 
15: if %deccounter% EQU 0 (set mnthtif=%mnthtif:~1,1%) 
 
16: rem input year 4 digits 
17: set shortfilename2=%longfilename:~2,4% 
18: rem input input year 2 digits 
19: set shortfilename3=%longfilename:~4,2% 
 
20: set InputDrive=%2 
21: set InputDir=%3 
22: set OutputDrive=%4 
23: set OutputDir=%5 
24: set gdalDir=%6 
25: set IlwDir=%7 
26: set UtilDir=%8 
 
27: cd\ 
28: %OutputDrive% 
29: cd %OutputDir% 
 
30: echo your current working directory = %OutputDrive%\%OutputDir% 
31: echo. 
32: echo. 
 
33: "%UtilDir%\wget\wget.exe"  http://igskmncngs600.cr.usgs.gov/ftp2/africa/emodis/sa%mnthtif%%shortfilename3%.zip 
 
34: echo off 
35: if not exist "%OutputDrive%\%OutputDir%\sa%mnthtif%%shortfilename3%.zip"  goto MESSAGE 
36: echo The file(s) "sa%mnthtif%%shortfilename3%.zip" has been retrieved and transferred to your current working directory 
37: echo. 
38: echo. 
 
39: GOTO START 
 
40: :MESSAGE 
41: echo The input file was not found in the archive. 
42: echo Check your Date stamp settings 
43: echo Your current Date stamp used is %longfilename% 
44: echo Data is retrieved from http://igskmncngs600.cr.usgs.gov/ftp2/africa/emodis/ 
45: echo Check also manually if the data exists on ftp archive (see link above) 
46: echo Internet has a transient nature - addresses might not be valid or has changed after some time! 
 
47: pause 
 
48: GOTO END 
 
49: :START 
 
50: "%UtilDir%\7z.exe" e sa%mnthtif%%shortfilename3%.zip 
 
51: ren sa%mnthtif%%shortfilename3%.tif emodis_ndvi%shortfilename2%%period%.tif 
 
52: "%gdalDir%\gdal_translate" -of ilwis emodis_ndvi%shortfilename2%%period%.tif 

temodis_ndvi%shortfilename2%%period%.mpr 
 
53: "%IlwDir%\ilwis.exe" -C %OutputDrive%\%OutputDir%\emodis_sa_ndvi%shortfilename2%%period%.mpr{dom=value;vr=-

1.000:1.000:0.0001}:=(%OutputDrive%\%OutputDir%\temodis_ndvi%shortfilename2%%period%-100)/100 
 
54: "%IlwDir%\ilwis.exe" -C setgrf %OutputDrive%\%OutputDir%\emodis_sa_ndvi%shortfilename2%%period%.mpr 

%UtilDir%\emodis_sa 
 
55: del sa%mnthtif%%shortfilename3%.tfw 
56: del emodis_ndvi%shortfilename2%%period%.tif 
57: del sa%mnthtif%%shortfilename3%.zip 
58: del temodis_ndvi%shortfilename2%%period%.mp* 
59: del temodis_ndvi%shortfilename2%%period%.grf 
 
60: :END 
61: "%IlwDir%\ilwis.exe" -C closeall 
---------------------------------------------------------------------------------------------------------------------------------------- 
End of Batch file listing 
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Although the content of the batch files can vary significantly, the sequence of activities is mostly the 
same: 
 

 Some remarks are given at the start of the batch file 
 Setting of the environment variables, passing over the parameters from the ILWIS scripts 
 Check if input data is available, if not go to the end of the batch routine 
 Copy the original data to a local disk 
 Import of the data into ILWIS format 
 Execute various ILWIS routines from the command prompt 
 Delete obsolete files 
 Close ILWIS tasks created by the batch routine 

 
Note that all batch routines show a command line window. Relevant information is contained in these 
windows. It is advised that the content of these windows is critically checked while waiting for the 
batch routine to finish. The batch files can be opened using a text editor. The name of the batch file 
executed can be obtained from the ILWIS command line string as given in chapter 2.5. Some import 
routines download time series of data (e.g. daily data for a month or year). Upon extraction of the file 
all data contained is imported using a batch looping procedure. For further information on how these 
procedures operate see also the reference given in chapter 2.7. Some files are large so adequate 
bandwidth is required for smooth operations. 
 
In the example given in the batch file listing a date stamp should have been entered as “022012”. The 
actual time stamp used is “022013” which is resulting in the fact that the input data cannot be found 
(as it is not available at this moment!) and the routine, after pressing <Enter> is aborted. Carefully 
inspect the date stamp and directory settings as indicated in the command line interpreter window as 
given in the figure below. 
 

Figure 2.5: Resulting message when entering wrong date-time stamp 

 
 
When appropriate, “quotation marks” are used to specify the location of a ‘directory\executable’ as well 
as for the input original file names to ensure that batch routines keep working if encountered spaces in 
(sub-) directory names and to process input files with complex file names. To ensure proper operation 
of the batch routines stick to the golden rules as given in chapter 1.2. 
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2.7 ADVANCED USE 

If certain operations have to be repeated on a continuous basis, e.g. import of certain products for 
which basically only the time stamp has to be modified the use of the ISOD toolbox menu might be 
cumbersome. From the main menu of ILWIS, the command line history can be checked. Select the 
appropriate string generated through the graphical user interface, modify the time stamp and execute 
the expression again by pressing <Enter>. 
 
It is advised however, to copy the command line string that is generated through the graphical user 
interface, available from the command line in the main menu of ILWIS, to the WINDOWS command 
line processor (CMD.exe). Delete the “!” from the start of the string and execute the expression. Within 
the string the date stamp can be easily modified. Eventually this line can be copied into a new text file 
and the file can be given an extension “.bat”. This file can then be executed from the DOS Command 
prompt as well. With multiple lines in such a batch file only having different “Date” stamps, time series 
can be created very efficiently. Additional information on how to conduct these procedures is 
described in the “GEONETCast – DevCoCast Application Manual”, online available at:  
http://www.itc.nl/Pub/WRS/WRS-GEONETCast/Application-manual.html. Also within this document an 
automated data retrieval and processing example is presented (see chapter 4.2.4).  
 

2.8 CONCLUDING REMARK 

With all the configuration settings provided you are now ready to utilize the ISOD Toolbox and explore 
the data that is freely available from the Internet. The main objective of this toolbox is to integrate 
these resources in an efficient manner into the Geographic Information System ILWIS. With the other 
toolboxes, allowing efficient import of the data disseminated through satellite based 
telecommunication systems, a multitude of archive and real time information is now at the disposal of 
the User Community. If you have links to other free internet resources and want to be able to use 
these also within the ISOD toolbox, please contact the EO Community contact (at: http://52north.org/ 
communities/earth-observation/community-contact) so new applications can be integrated in an 
updated version / new release of the toolbox and others can make use of it as well. 
 
This document is providing links to various online metadata and background reference resources, next 
to the data archives itself (within the toolbox pop-up menu). It should be noted that due to the transient 
nature of the internet some of these links might not be up to date anymore. In case this is noted 
please provide your observations to the EO Community contact as well, using the link given above. 
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3. EXPLORING THE INTERNET RESOURCES USING THE ISOD TOOLBOX 

3.1  INTRODUCTION 

Various environmental (time series) data resources are currently available on the internet relevant for 
a multitude of applications. Users are often not aware of these resources and if so, they might find it 
difficult to import the (multi-temporal) data into a GIS. In order to overcome these bottlenecks, the “In 
Situ and Online Data” Toolbox has been developed. When operating the toolbox, the data is in most 
cases automatically retrieved (when possible!) and ingested into an ILWIS format. The data exchange 
library within ILWIS allows the user the export the data to other formats; furthermore the extensive 
image, vector and thematic data processing capability of ILWIS can be used for further data analysis. 
 
Within this chapter attention is given to the various data resources which can be retrieved using the 
toolbox. Additional relevant background information is presented here to obtain a better understanding 
of the data which is needed if further analysis is envisaged. References to (online) documentation are 
provided as well. In the following chapter a number of practical exercises are presented using the 
toolbox to become familiar with its functionality.  
 
The toolbox menu (XML Version 1.1) as presented in figure 2.1 has a number of main menu items. 
This menu sequence is followed below as well to present the relevant background details. 

3.2 ONLINE IN SITU CLIMATE DATABASES 

 NCDC Integrated Surface Data (ISD) 3.2.1

The data summaries provided here are based on data exchanged under the World Meteorological 
Organization (WMO) World Weather Watch Program according to WMO Resolution 40.  This allows 
WMO member countries to place restrictions on the use or re-export of their data for commercial 
purposes outside of the receiving country.  Data for selected countries may, at times, not be available 
through this system.    
 
Those countries' data summaries and products which are available here are intended for free and 
unrestricted use in research, education and other non-commercial activities. The data are available via 
http://www.ncdc.noaa.gov/cgi-bin/res40.pl?page=gsod.html and ftp://ftp.ncdc.noaa.gov/pub/data/gsod. 
 
The input data used in building these daily summaries are the Integrated Surface Data (ISD), which 
includes global data obtained from the USAF Climatology Centre.  The latest daily summary data are 
normally available 1-2 days after the date-time of the observations used in the daily summaries. The 
online data files begin with 1929, and over 9000 stations' data are typically available.   
 
The daily elements included in the dataset (available for each station) are: mean temperature, mean 
dew point, mean sea level pressure, mean station pressure, mean visibility, mean wind speed, 
maximum sustained wind speed, maximum wind gust, maximum temperature, minimum temperature, 
precipitation amount, snow depth and indicator for the occurrence of: fog, rain or drizzle, snow or ice 
pellets, hail, thunder and tornado/funnel cloud. Upon import the data is converted to SI units. 

 NOAA CPC-FEWS GTS Data 3.2.2

One important source of information used by NOAA/CPC and many other meteorological agencies for 
weather and climate applications is the gauge-observed precipitation reports transmitted through the 
Global Telecommunications System (GTS). Together with station reports from other national and 
international sources, the GTS gauge data are used to monitor and assess the climate at station 
locations and as inputs to define analyzed fields of global and regional precipitation. 
 
The Global Telecommunication System (GTS) is the coordinated global system of telecommunication 
facilities and arrangements for the rapid collection, exchange, and distribution of observed and 
processed meteorological information within the framework of the World Weather Watch (WWW). 
Station reports of precipitation, together with those of many other physical variables, are exchanged 
routinely among the World Meteorological Organization (WMO) member countries through the GTS 
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network. At NOAA / CPC, these precipitation reports are received and processed to form a database 
of GTS gauge-based daily precipitation. Starting from October 1977, the GTS daily gauge database is 
updated on a real-time basis. On average, daily reports are available from about 6000 GTS stations. 
The GTS gauge network is relatively dense over United States, Western Europe, and east coasts of 
Australia and China, while it is very sparse over several regions including equatorial Africa and 
Amazon (source: Quality Control of Daily Precipitation Reports at NOAA/CPC by Mingyue Chen, 
Pingping Xie and CPC Quality Control Working Group, Climate Prediction Center, CPC/NCEP/ NOAA, 
available at http://ams.confex.com/ams/pdfpapers/131381.pdf).  
 
The rainfall and temperature (minimum and maximum) up to a year before present can be obtained 
online from ftp://ftp.cpc.ncep.noaa.gov/fews/gts. 

 Current Weather Conditions from TAF 3.2.3

In meteorology and aviation, TAF is a format for reporting weather forecast information, particularly as 
it relates to aviation. "TAF" is an acronym of Terminal Aerodrome Forecast or, in some countries, 
Terminal Area Forecast. TAFs apply to a five statute mile radius from the center of the airport runway 
complex. Generally, TAFs can apply to a 9- or 12-hour forecast; some TAFs cover an 18- or 24-hour 
period; and as of November 5, 2008, TAFs for some major airports cover 30 hours periods. The 
date/time group reflects the new 30 hour period in Coordinated Universal Time (UTC), as always. 
TAFs complement and use similar encoding to METAR reports. They are produced by a human 
forecaster based on the ground. For this reason there are fewer TAF locations than there are 
METARs. TAFs can be more accurate than Numerical Weather Forecasts, since they take into 
account local, small-scale, geographic effects (source: Wikipedia). 
 
Terminal Aerodrome Forecasts are routinely issued every 6 hours, and are valid 24 hours from 
issuance time.  The product provides a forecast of cloud heights and ceilings, wind direction and 
speed and associated wind shear, visibilities, and prevailing weather conditions.  An explanation on 
the various codes used can be found at http://www.spacearchive.info/taf.htm and individual reports, in 
meteorological code, can also be retrieved from http://weather.noaa.gov/weather/taf.shtml when 
entering the four-character ICAO Location Indicator. Here the current weather reports from the TAF 
reports are processed. 

3.3 GAUGE BASED AND SATELLITE DERIVED RAINFALL DATA 

Routines have been developed to integrate the online (satellite derived) precipitation products from the 
NOAA Climate Prediction Centre, EUMETSAT, NASA and FEWS NET RFE for Africa. Further details 
are presented below on the various products that can be retrieved.  

 CPC Gauge-Based Analysis of Global Daily Precipitation 3.3.1

This data set is the first product of the CPC Unified Precipitation Project that is underway at NOAA 
Climate Prediction Centre (CPC). The primary goal of the project is to create a suite of unified 
precipitation products with consistent quantity and improved quality by combining all information 
sources available at CPC and by taking advantage of the optimal interpolation (OI) objective analysis 
technique. 
 
The coverage is global (land only) at 0.5 degree spatial resolution. The temporal resolution is daily and 
the data is available from the 1st of January 1979 – Present: 
 
    1979 – 2005:  Retrospective Version (30K+ gauges) 

ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/V1.0/  
    2006 - Present: Real-time version   (~17K gauges)  

ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/RT/ 
 
Other relevant background documents are: 

 On the Interpolation algorithm:  
Xie, P., A. Yatagai, M. Chen, T. Hayasaka, Y. Fukushima, C. Liu and S. Yang (2007): A 

gauge-based analysis of daily precipitation over East Asia, J. Hydrometeorol., 8, 607. 626.  
ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/DOCU/Xie_et_al_2007_JHM_EAG.pdf  
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 On the Gauge Algorithm Evaluation:  
Chen, M., W. Shi, P. Xie, V. B. S. Silva, V E. Kousky, R. Wayne Higgins and J. E. Janowiak 
(2008): Assessing objective techniques for gauge-based analyses of global daily precipitation, 
J. Geophys. Res., 113, D04110, doi:10.1029/2007JD009132.    
ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/DOCU/Chen_et_al_2008_JGR_Gauge_Algo.pdf   

 On the Construction of the Daily Gauge Analysis: 
Chen, M., P. Xie, and Co-authors (2008), CPC Unified Gauge-based Analysis of Global Daily 
Precipiation, Western Pacific Geophysics Meeting, Cairns, Australia, 29 July - 1 August, 2008.    
ftp://ftp.cpc.ncep.noaa.gov/precip/CPC_UNI_PRCP/GAUGE_GLB/DOCU/Chen_et_al_2008_Daily_Gauge_Anal.pdf  

 CMORPH 3.3.2

CMORPH (CPC MORPHing technique) produces global precipitation analyses at very high spatial and 
temporal resolution. This technique uses precipitation estimates that have been derived from low 
orbiter satellite microwave observations exclusively, and whose features are transported via spatial 
propagation information that is obtained entirely from geostationary satellite IR data. At present it is 
incorporating precipitation estimates derived from the passive microwaves aboard the DMSP 13, 14 & 
15 (SSM/I), the NOAA-15, 16, 17 & 18 (AMSU-B), and AMSR-E and TMI aboard NASA's Aqua and 
TRMM spacecraft, respectively. These estimates are generated by algorithms of Ferraro (1997) for 
SSM/I, Ferraro et al. (2000) for AMSU-B and Kummerow et al. (2001) for TMI. Note that this technique 
is not a precipitation estimation algorithm but a means by which estimates from existing microwave 
rainfall algorithms can be combined. Therefore, this method is extremely flexible such that any 
precipitation estimates from any microwave satellite source can be incorporated.  
 
With regard to spatial resolution, although the precipitation estimates are available on a grid with a 
spacing of 8 km (at the equator), the resolution of the individual satellite-derived estimates is coarser 
than that - more on the order of 12 x 15 km or so. The finer "resolution" is obtained via interpolation.  
 
In effect, IR data are used as a means to transport the microwave-derived precipitation features during 
periods when microwave data are not available at a location. Propagation vector matrices are 
produced by computing spatial lag correlations on successive images of geostationary satellite IR 
which are then used to propagate the microwave derived precipitation estimates. This process 
governs the movement of the precipitation features only. At a given location, the shape and intensity of 
the precipitation features in the intervening half hour periods between microwave scans are 
determined by performing a time-weighting interpolation between microwave-derived features that 
have been propagated forward in time from the previous microwave observation and those that have 
been propagated backward in time from the following microwave scan. This latter step is referred to as 
"morphing" of the features (source: http://www.cpc.ncep.noaa.gov/products/janowiak/cmorph_ 
description.html).  
 
The 8-km 30 minute CMORPH data sets can be found on the ftp.cpc.ncep.noaa.gov server in the 
“precip/global_CMORPH/30min_8km” directory. The CMORPH 0.25 degree – 3 hours product can be 
obtained from the ftp.cpc.ncep.noaa.gov server in the “precip/global_CMORPH/3-hourly_025deg” 
directory and all units are mm/hr. Data is available from 7 December 2002 onwards. 

 QMORPH 3.3.3

Because the CMORPH estimates are available about 18 hours after real-time, users that require more 
timely estimates may be interested in "QMORPH" estimates, which are similar to CMORPH estimates, 
except that the passive microwave precipitation features are propagated via IR data forward in time 
only with no morphing. QMORPH estimates are available within 3 hours of real time, and the past one 
week of QMORPH data are available online. 

 TRMM MERGED HQ/INFRARED PRECIPITATION  3.3.4

The Tropical Rainfall Measuring Mission (TRMM) is a joint U.S.-Japan satellite mission to monitor 
tropical and subtropical precipitation and to estimate its associated latent heating. The rainfall 
measuring instruments on the TRMM satellite include the Precipitation Radar (PR), an electronically 
scanning radar operating at 13.8 GHz; TRMM Microwave Image (TMI), a nine-channel passive 
microwave radiometer; and Visible and Infrared Scanner (VIRS), a five-channel visible/infrared 
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radiometer (Source: http://gcmd.gsfc.nasa.gov/records/GCMD_GES_DISC_TRMM_3B42_daily_V7. 
html).  
 
The purpose of the 3B42 algorithm is to produce TRMM-adjusted merged-infrared (IR) precipitation 
and root-mean-square (RMS) precipitation-error estimates. The algorithm consists of two separate 
steps. The first step uses the TRMM VIRS and TMI orbit data (TRMM products 1B01 and 2A12) and 
the monthly TMI/TRMM Combined Instrument (TCI) calibration parameters (from TRMM product 
3B31) to produce monthly IR calibration parameters. The second step uses these derived monthly IR 
calibration parameters to adjust the merged-IR precipitation data, which consists of GMS, GOES-E, 
GOES-W, Meteosat and NOAA data. The final gridded, adjusted merged-IR precipitation (mm/hr) and 
RMS precipitation-error estimates have a 3-hourly temporal resolution and a 0.25-degree by 0.25-
degree spatial resolution. Spatial coverage extends from 50 degrees south to 50 degrees north 
latitude. The daily accumulated (beginning at 00Z and ending at 21Z; unit: mm) rainfall product is 
derived from this 3-hourly product. 
 
The daily and weekly data from TRMM are based on algorithm 3B-42. For further information consult 
http://trmm.gsfc.nasa.gov/3b42.html. The 3B-42 estimates are produced in four stages; (1) the 
microwave estimates precipitation are calibrated and combined, (2) infrared precipitation estimates are 
created using the calibrated microwave precipitation, (3) the microwave and IR estimates are 
combined, and (4) rescaling to monthly data is applied. Each precipitation field is best interpreted as 
the precipitation rate effective at the nominal observation time. 
 
As from 22 May 2012 Version 7 of TRMM product 3B42 has been implemented, which supersedes all 
previous versions. A routine has been added to retrieve the 3 hourly data and aggregates it to a daily 
total (unit is mm/day).  
 
Other relevant background documents are: 
 

 Huffman, G.J., R.F. Adler, B. Rudolph, U. Schneider, and P. Keehn, 1995: Global Precipitation 
Estimates Based on a Technique for Combining Satellite-Based Estimates, Rain Gauge 
Analysis, and NWP Model Precipitation Information, J. Clim., 8, 1284-1295.  

 
 Huffman, G.J., 1997: Estimates of Root-Mean-Square Random Error for Finite Samples of 

Estimated Precipitation, J. Appl. Meteor., 1191-1201.  
 

 Huffman, G.J., R.F. Adler, P. Arkin, A. Chang, R. Ferraro, A. Gruber, J. Janowiak, A. McNab, 
B. Rudolph, and U. Schneider, 1997: The Global Precipitation Climatology Project (GPCP) 
Combined Precipitation Dataset, Bul. Amer. Meteor. Soc., 78, 5-20.  

 
 Huffman, G.J., R.F. Adler, D.T. Bolvin, G. Gu, E.J. Nelkin, K.P. Bowman, Y. Hong, E.F. 

Stocker, D.B. Wolff, 2007: The TRMM Multi-satellite Precipitation Analysis: Quasi-Global, 
Multi-Year, Combined-Sensor Precipitation Estimates at Fine Scale. J. Hydrometeor., 8(1), 
38-55.  

 
 Huffman, G.J., R.F. Adler, M. Morrissey, D.T. Bolvin, S. Curtis, R. Joyce, B McGavock, J. 

Susskind, 2001: Global Precipitation at One-Degree Daily Resolution from Multi-Satellite 
Observations.  J. Hydrometeor., 2(1), 36-50. 

 Last 24 hour MPE from EUMETSAT 3.3.5

This utility automatically extracts to a specific output directory the Multi Sensor Precipitation Estimates 
(MPE) produced by EUMETSAT, made available about 1 hour after satellite recording on their 24 hour 
rolling archive (available at: http://oiswww.eumetsat.org/SDDI/html/grib.html). The user can select the 
MPE derived from METEOSAT-7 and MSG. Once all data is downloaded, the files are imported into 
an ILWIS format. A loop processing routine is applied to import the various rainfall instances. This 
routine needs a fast internet connection as a lot of files are transferred (48 for MET-7 and 96 from 
MSG). Rainfall intensities are given in mm per hour. Using generic GIS functionality the various rainfall 
instances can be aggregated. 
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 FEWSNET RAINFALL AND CLIMATOLOGY FOR AFRICA  3.3.6

These rainfall estimates are created by the Climate Prediction Center for the United States Agency for 
International Development (USAID) Famine Early Warning System (FEWS) project to assist in drought 
monitoring and flood forecasting efforts throughout Africa.   
 
The rainfall algorithm called RFE1.0 uses infrared temperature satellite data, rain gauge data, 
modeled wind and relative humidity data to compute ten day rainfall estimates.  Meteosat-5 IR 
temperature data is first used to compute estimated rainfall via the GOES Precipitation Algorithm 
(GPI).  Modeled relative humidity and wind data is then compared to topographical data to estimate 
cross-terrain flow as orographic precipitation.  These two estimates are then compared to Global 
Telecommunications System (GTS) rain gauge measurements, and ground truthing is performed to 
remove bias and create the final rainfall estimate. RFE Version 1.0 data is available from 1995-2000. 
The algorithm used to create these estimates was replaced on January 1, 2001 and is no longer 
operational. From 1995-2000, each 10-day rainfall estimate covers the domain from 20W-55E and 
40S-20N with a resolution of 0.1 degree. 
 
The RFE Version 2.0 algorithm is based on the Xie method and is currently employed to create the 
RFE as operational product at the NOAA/Climate Prediction Center in association with USAID/FEWS-
NET. The spatial resolution is 0.1 degree and the bounding coordinates are from 40S to 40N in 
latitude, and 20W to 55E in longitude, covering the whole African continent. Data is available from 
2000 onwards. Maps of daily, decadal, and monthly rainfall estimates, as well as documentation on 
the RFE algorithm methodology can be consulted at http://www.cpc.ncep.noaa.gov/products/fews/ 
rfe.shtml. Longer duration products are created by accumulation of the daily data. 
 
Also RFE based climatology data is produced by the Climate Prediction Center. Daily, dekadal and 
monthly means in mm per respective time interval are currently based on a climatological record from 
1983 till 2011. The files contain climatological rainfall estimates over the African continent utilizing the 
Africa Rainfall Estimate Climatology Version 2 (CPC-ARC2) - method, see also 
http://www.cpc.ncep.noaa.gov/products/fews/AFR_CLIM/afr_clim.shtml. Also further information on 
the ARC2 dataset is provided there. The geographical extent is identical compared to the RFE2 
rainfall estimate. Also check http://www.cpc.ncep.noaa.gov/products/fews/AFR_CLIM/AMS_ARC2a. 
pdf. 
 
References: 
 Xie, P. and P.A. Arkin, 1996: Analyses of Global Monthly Precipitation Using Gauge 

Observations, Satellite Estimates, and Numerical Model Predictions. J. Climate: 9, 840-858. 
 
Comparison of satellite derived precipitation products: 
 T. Cohen Liechti, J. P. Matos, J.-L. Boillat and A. J. Schleiss (2012): Comparison and evaluation 

of satellite derived precipitation products for hydrological modeling of the Zambezi River Basin. 
Hydrol. Earth Syst. Sci., 16, 489-500, 2012.  http://www.hydrol-earth-syst-
sci.net/16/489/2012/hess-16-489-2012.html 

 D.A. Hughes. Comparison of satellite rainfall data with observations from gauging station 
networks  http://eprints.ru.ac.za/470/1/Hughes_Comparison_of_satellite_rainfall.pdf 

 Nick Novella and Wassila Thiaw (2009): Validation of Satellite-Derived Rainfall Products over 
the Sahel 2009 EUMETSAT Meteorological Satellite Conference, Bath, United Kingdom 21 - 25 
September 2009 (http://www.eumetsat.int/Home/Main/AboutEUMETSAT/Publications/ 
ConferenceandWorkshopProceedings/2009/SP_201001515267179?l=en) 

 TAMSAT Rainfall archive for Africa 3.3.7

The TAMSAT group from the University of Reading, UK, are producing ten-daily (dekadal) and 
monthly rainfall estimates and anomalies derived from Meteosat Thermal Infra-Red (TIR) channels 
based on the recognition of storm clouds and calibration against ground-based rain gauge data (see 
also http://www.met.reading.ac.uk/tamsat/about/). Using this set of retrieval routines the 10 day 
accumulated RFE rainfall product can be retrieved as well as the monthly accumulated rainfall 
products. Furthermore decadal anomaly and monthly anomaly rainfall products can be retrieved. The 
online archive currently contains 10 day and monthly rainfall data from 1983 onwards. Also 10-year 
rainfall climatology (from 2000-2009) is available from here. The data covers Africa and has a spatial 
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resolution of 0.0375 degree; Geographic coordinates in lat-lon. The seasonal rainfall totals are not 
used within the ISOD Toolbox; these can be easily constructed by the User using an aggregation 
function.  

3.4 FEWSNET Global Potential Evapotranspiration 

The daily global potential evapotranspiration (PET) is calculated from climate parameter data that is 
extracted from Global Data Assimilation System (GDAS) analysis fields. The GDAS data are 
generated every 6 hours by the National Oceanic and Atmospheric Administration (NOAA). The GDAS 
fields used as input to the PET calculation include air temperature, atmospheric pressure, wind speed, 
relative humidity, and solar radiation (long wave, short wave, outgoing and incoming). PET is 
computed for each 6 hour period and then summed to obtain daily totals. A day is defined as 
beginning at 00 hours GMT. 
 
The daily PET is calculated on a spatial basis using the Penman-Monteith equation (the formulation of 
Shuttleworth (1992) for reference crop evaporation is used). These equations were standardized in 
accordance with the FAO publication 56 for the 6-hourly calculations (Allen et al, 1998).  
 
The daily PET values are scaled up (i.e. multiplied) by a factor of 100 to preserve the precision to .01 
mm. The PET data have a 1 degree ground resolution and are global in spatial extent (i.e. -180 to 
+180 longitude by -90 to +90 latitude) (source: http://earlywarning.usgs.gov/fews/global/web/readme. 
php?symbol=pt).  
 
The Year Collection of daily PET images are ~25 Mb per file (year). The naming convention is 
pet_YYYY.tar.gz where YYYY is the 4 digit year. These files are containing a year of daily (365 or 366 
in leap year) data files. 
 
The Month Collection of daily PET images are ~ 2 Mb per file (month). The naming convention is 
pet_YYYYMM.tar.gz where YYYY is the 4 digit year and MM is the 2 digit month of year. These files 
are containing a month of daily (28-31) data files. For the individual day PET images also retrieval and 
processing routines are developed. 
Yearly global PET data is available from 2001 onwards up to the last full year. Monthly data can also 
be extracted from 2001 onwards. Daily global PET data can be retrieved up to a year before present.  
Further information can be obtained from http://earlywarning.usgs.gov/fews/global/web/ 
dwnglobalpet.php. Upon retrieval / import the data is converted to mm / per day.  
 
References for Calculations: 
 Allen, R.G., L. Pereira, D. Raes, and M. Smith, 1998. Crop Evapotranspiration, Food and 

Agriculture Organization of the United Nations, Rome, Italy. FAO publication 56. ISBN 92-5-
104219-5. 290p. 

 Shuttleworth, W.J., 1992. Evaporation. In D. Maidment, Handbook of Hydrology. McGraw-Hill 
 Smith, M. 1992. Expert consultation on the revision of FAO methodologies for crop water 

requirements. FAO, Rome, Italy. 60pp.  

3.5  FEWSNET NOAA - eMODIS NDVI for Africa 

 FEWSNET NOAA DERIVED NDVI FOR AFRICA  3.5.1

Introduction: The Normalized Difference Vegetation Index (NDVI) provides a measure of the amount 
and vigour of vegetation at the land surface. The magnitude of NDVI is related to the level of 
photosynthetic activity in the observed vegetation. In general, higher values of NDVI indicate greater 
vigour and amounts of vegetation. NDVI is derived from data collected by National Oceanic and 
Atmospheric Administration (NOAA) satellites, and processed by the Global Inventory Monitoring and 
Modelling Studies group (GIMMS) at the National Aeronautical and Space Administration (NASA). 

The NOAA-Advanced Very High Resolution Radiometer (AVHRR) collects the data that are used to 
produce the NDVI. The scanning radiometer (comprised of five channels) is used primarily for weather 
forecasting; however, there are an increasing number of other applications, e.g., drought monitoring. 
NDVI is calculated from two channels of the AVHRR sensor, the near-infrared (NIR) and visible (VIS) 
wavelengths, using the following algorithm: 
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NDVI = (NIR - VIS)/(NIR + VIS) 
 
NDVI is a nonlinear function that varies between -1 and +1 (undefined when NIR and VIS are zero). 
Values of NDVI for vegetated land generally range from about 0.1 to 0.7, with values greater than 0.5 
indicating dense vegetation. 
 
Since the late 1980's, the Famine Early Warning System (FEWS) has used AVHRR data to produce 
dekadal (10-day) composite NDVI images of Africa and has built a valuable archive of these data from 
mid-1981 to present. 
  
NDVI-g data background: EROS processes and archives a dekadal (i.e. ~10 days, 36/year) Africa 
NDVI product from the NASA GIMMS group called NDVI-g. The dataset is inter-calibrated with SPOT 
Vegetation NDVI, and uses NOAA-17 data since January 2004. The NOAA-17 NDVI data have also 
been inter-calibrated with NOAA-16 and previous NDVI products. These data are available from the 
African Data Dissemination Service server (http://earlywarning.usgs.gov/fews/). Note that the NDVI 
data from July dekad 1, 1981 through December dekad 3, 2008 are NDVI-g. The data from January 
dekad 1, 2008 to present are NDVI-rg. NASA has stated that the NDVI-rg data will be updated to the 
archival NDVI-g product approximately every 6-12 months. 
 
FEWS-NET NDVI data originates from the NASA GIMMS group. For more information about AVHRR 
data, NDVI processing and for proper acknowledgement of these data in any report or publication, see 
the references at the end of this section.  
 
NDVI-g data characteristics: Data source is the NASA - GIMMS group, time step of the data is 10-
day (dekadal), and spatial resolution is 8km. The projection used is Albers equal area conic, using the 
Clarke ellipsoid, the applied temperature threshold for cloud screening is 285 Kelvin and the file format 
is byte (8 bit). The satellite that acquired the data for any given period is provided below: 
 

NOAA 7   periods   (Jul 81 - Feb 85) 
NOAA 9   periods   (Feb 85 - Nov 88) 
NOAA 11 periods   (Nov 88 - Sep 94) 
NOAA 9   periods (descend) (Sep 94 - Jan 95) 
NOAA 14 periods  (Jan 95 - Oct 00) 
NOAA 16 periods   (Nov 00 - Dec 03) 
NOAA 17 periods   (Jan 04 - present) 

 
Processing Details: No correction has been applied to correct for atmospheric effects due to water 
vapor, Rayleigh scattering or stratospheric ozone. Maximum value compositing has been used, with a 
forward binning procedure method implemented. A stratospheric aerosol correction has been applied 
during April 82-Dec 84 and June 91-Dec 93 to correct for stratospheric aerosols due to volcanic 
eruptions (Tanre, Holben and Kaufman 91). The corrections use a hybrid of retrieved optical 
thicknesses (Vermott et al. 95) and modeled thicknesses from GISS.  
 
Artefacts in the NDVI due to satellite drift have been corrected using the empirical mode 
decomposition (EMD) procedure. The correction is especially important in tropical regions. For details 
see the paper of Pinzon et al 2004, referenced below. The VIg correction has been applied to the 
GIMMS VId data that has had the desert calibration applied for NOAA 7-14 (Los 1998). 
  
Scaling Info: NDVI is archived as byte data files. In the formula below, the data, once imported, is 
referred to as the 'raw' data. To recover the -1 to 1 range of NDVI, use the following formula:  
 

NDVI = raw/250 
 
After conversion, Water pixels have a value of 1.0200, and 1.0160 are masked pixels, and missing are 
1.0120 (source: http://earlywarning.usgs.gov/fews/africa/web/readme.php?symbol=nd). This algorithm 
is applied when processing the data using the ISOD toolbox. 
 
The AVHRR sensor (the sensor used to derive the Africa dekadal AVHRR NDVI) onboard the NOAA-
17 satellite has been encountering major degradation problems. The NDVI data derived from the 
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NOAA-17 AVHRR sensor are no longer valid and are no longer staged or distributed until further 
notice. 
 
NASA is currently in the process of converting from the NOAA-17 AVHRR sensor to the NOAA-18 
AVHRR sensor. NASA intends to calibrate and reprocess the AVHRR NDVI using the NOAA-18 
sensor data back to the beginning of 2010. When this transition has been completed and production 
using the NOAA-18 sensor is established, NASA will continue staging and distributing the AVHRR 
NDVI product. For more recent products the eMODIS derived NDVI can be applied, for further 
information see the next section. 
 
References: 
 Tucker C.J., J.E. Pinzón, M.E. Brown, D. Slayback, E.W. Pak, R. Mahoney, E. Vermote, and N. 

El Saleous, 2005. "An Extended AVHRR 8-km NDVI Data Set Compatible with MODIS and 
SPOT Vegetation NDVI Data." International Journal of Remote Sensing 26(20): 4485-4498. 

 Pinzon J., Brown M.E., Tucker C.J. (2004). Satellite time series correction of orbital drift artifacts 
using empirical mode decomposition. Hilbert-Huang Transform: Introduction and Applications. 
N. Huang: Chapter 10, Part II. Applications.  

 Tucker, C. J. (1979). "Red and Photographic Infrared Linear Combinations for Monitoring 
Vegetation." Remote Sensing of Environment 8: 127-150. 

 Los, S. (1998). "Estimation of the Ratio of Sensor Degradation Between NOAA AVHRR 
Channels 1 and 2 from Monthly NDVI Composites." IEEE Transactions on Geoscience and 
Remote Sensing 36(1): 206-213.  

 Pinzón, J. E. (2002). "Using HHT to successfully uncouple seasonal and interannual 
components in remotely sensed data." SCI 2002 Proceedings, July 14 - 18, Orlando, Florida, 
USA. 

 Pinzón, J. E., J. F. Pierce, and C. J. Tucker (2001). "Analysis of remote sensing data using 
Hilbert-Huang transform." SCI 2001 Proceedings, July 22 - 25, Orlando, Florida, USA.  

 Tanre, D., B. N. Holben and Y. J. Kaufman (1992). "Atmospheric Correction Algorithms for 
NOAA-AVHRR products: Theory and Application." IEEE Transactions Geoscience and Remote 
Sensing 30: 231-248.  

 Vermote, E. and Y. J. Kaufman (1995). "Absolute calibration of AVHRR visible and near-infrared 
channels using ocean and cloud views." International Journal of Remote Sensing 16(13): 2317-
2340. 

 FEWSNET EMODIS DERIVED NDVI, ANOMALY AND HISTORICAL DATA FOR AFRICA  3.5.2

Expedited MODIS (eMODIS) is a process for creating a community-specific suite of vegetation 
monitoring products based on the National Aeronautics and Space Administration’s (NASA) Earth 
Observing System (EOS) Moderate Resolution Imaging Spectroradiometer (MODIS) and produced at 
the U.S. Geological Survey’s (USGS) Earth Resources Observation and Science (EROS) Centre. 
Real-time and historical Normalized Difference Vegetation Index (NDVI) products are composited in 
10-day intervals every 5 days on a Geographic mapping grid. 
 
eMODIS 10-day maximum-value composite NDVI images at 250m spatial resolution are used to 
monitor vegetation condition. NDVI is a measure of the density of chlorophyll contained in vegetative 
cover and is defined as (NIR – RED) / (NIR + RED), where NIR is the near-infrared reflectance and 
RED is the visible-red reflectance. This vegetation product is calculated from MODIS L1B Terra 
surface reflectances, corrected for molecular scattering, ozone absorption, and aerosols (source: 
http://earlywarning.usgs.gov/fews/africa/index.php).   
 
The NDVI and NDVI Anomaly maps are the product of a temporally smoothed 250m NDVI data set.   
A time series smoothing technique developed by Swets and others (1999) was used to smooth NDVI 
composites for the years 2001 through 2010.  The technique uses a weighted least squares linear 
regression approach to “correct” observations that are of poor quality due to clouds or other 
atmospheric contamination. This smoothed time series was used to derive a 10-year mean NDVI on a 
pixel-by-pixel basis for each of the 72 composite periods per year.  As current-year composites 
become available, they are added to the time series and smoothed, resulting in a smoothed composite 
comparable to the historical mean for a given 10–day period.  
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Reference:  
 Swets, D.L., Reed, B.C., Rowland, J.D. & Marko, S.E. (1999): A weighted least-squares 

approach temporal NDVI smoothing. In: 1999 ASPRS Annual Conference: From Image to 
Information, Portland, Oregon, May 17-21. Proceedings: Bethesda, Maryland, American Society 
for Photogrammetry and Remote Sensing. 

   
The following products can be retrieved: 

 Temporally Smoothed NDVI – Smoothed 10-day NDVI composite.  
 Short-term Mean Anomaly - Anomalies represent a subtraction of the mean NDVI values 

(2001-2010) for a 10-day period from current-year values for the same period, rendering an 
image where negative values portray less vigorous vegetation than average, and positive 
values represent areas that are more vigorous in the current year.  

 Previous Year Difference – The difference image is a subtraction of the current year NDVI 
values from those of the previous year. 

 Short-term Mean – mean per period derived for a time series from 2001-2010. 
 
Other relevant parameters are:  

 MODIS NDVI data are stretched (mapped) linearly (to byte values) as follows: 
Data range: [-1.0, 1.0] -> [0, 200], Invalid Values: 201 – 255, formula applied:  
NDVI = (value – 100) / 100;  example:  [ (150 – 100) / 100 = 0.5 NDVI ] 

 Anomaly / Difference Classification: The absolute difference and anomaly images are 
stretched from - 0.3 to 0.3 NDVI.  The area of relatively no difference is approximately -0.05 – 
0.05. The original data is provided in GeoTIFF format and transformed to ILWIS format. 

 The coordinate system used is Geographic, the units are in decimal degrees, spheroid used 
is WGS84. Pixel size in x and y direction is 0.002 degree. 

 
All parameters above are implemented during the product extraction – processing routines when using 
the ISOD toolbox. The routines allow retrieval and processing of the recent 2 years data as well as the 
historical NDVI data from 2001 onwards and the short term mean. 

3.6 GLOBAL ELEVATION DATA 

 GMTED 2010 3.6.1

The USGS and the NGA have collaborated on the development of a notably enhanced global 
elevation model named the GMTED2010 that replaces GTOPO30 as the elevation dataset of choice 
for global and continental scale applications. The new model has been generated at three separate 
resolutions (horizontal post spacing) of 30 arc-seconds (about 1 kilometer), 15 arc-seconds (about 500 
meters), and 7.5 arc-seconds (about 250 meters). This new product suite provides global coverage of 
all land areas from lat 84°N to 56°S for most products, and coverage from 84°N to 90°S for several 
products. GMTED2010 is based on data derived from 11 raster based elevation sources. 
 
The new elevation products have been produced using the following aggregation methods: minimum 
elevation, maximum elevation, mean elevation, median elevation, standard deviation of elevation, 
systematic subsample and breakline emphasis. Metadata have also been produced to identify the 
source and attributes of all the input elevation data used to derive the output products. Many of these 
products will be suitable for various regional and continental applications, such as climate modeling, 
continental-scale land cover mapping, extraction of drainage features for hydrologic modeling, and 
geometric and radiometric correction of medium and coarse resolution satellite image data. The global 
aggregated vertical accuracy of GMTED2010 can be summarized in terms of the resolution and 
RMSE of the products with respect to a global set of control points (estimated global accuracy of 6 m 
RMSE) provided by NGA. At 30 arc-seconds, the GMTED2010 RMSE range is between 25 and 42 
meters; at 15 arc-seconds, the RMSE range is between 29 and 32 meters; and at 7.5 arc-seconds, the 
RMSE range is between 26 and 30 meters. GMTED2010 is a major improvement in consistency and 
vertical accuracy over GTOPO30, which has a 66 m RMSE globally compared to the same NGA 
control points. In areas where new sources of higher resolution data were available, the GMTED2010 
products are substantially better than the aggregated global statistics; however, large areas still exist, 
particularly above 60 degrees North latitude that lack good elevation data. As new data become 
available, especially in areas that have poor coverage in the current model, it is hoped that new 
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versions of GMTED2010 might be generated and thus gradually improve the global model (source: 
http://pubs.usgs.gov/of/2011/1073/pdf/of2011-1073.pdf). The routines within the ISOD toolbox retrieve 
the breakline emphasis elevation products for the various resolutions. 

 SRTM Version 4 3.6.2

The SRTM digital elevation data, produced by NASA originally, was a major breakthrough in digital 
mapping of the world, and provides a major advance in the accessibility of high quality elevation data 
for large portions of the tropics and other areas of the developing world. The SRTM digital elevation 
data provided by CGIAR has been processed to fill data voids. The data is provided in an effort to 
promote the use of geospatial science and applications for sustainable development and resource 
conservation in the developing world. Digital elevation models (DEM) for the entire globe, covering all 
of the countries of the world, are available. The SRTM 90m DEM's have a resolution of 90m at the 
equator, and are provided in mosaiced 5 by 5 degree tiles. All are produced from a seamless dataset 
to allow easy mosaicking (source: http://srtm.csi.cgiar.org/). The data is projected in a Geographic 
(Lat/Long) projection, with the WGS84 horizontal datum and the EGM96 vertical datum. For further 
information on the SRTM Version 4 details and the product history consult the CGIAR website given 
above. 
 
The toolbox routine calculates the corresponding index number from the lower left hand Latitude and 
Longitude coordinate pair and subsequently extracts the elevation tile. The data is currently 
downloaded from http://droppr.org/srtm/v4.1/6_5x5_TIFs/. The addresses for the other mirror sites are 
included in the batch file (SRTM4_import.bat). It was found that the selected address was facilitating 
faster downloads. The SRTM data is retrieved in GeoTIFF format and transformed into ILWIS. 

 ASTER GDEM Version 2 3.6.3

In 2009, NASA and the Ministry of Economy, Trade and Industry (METI) of Japan released a Global 
Digital Elevation Model (GDEM) to users worldwide at no charge as a contribution to the Global Earth 
Observing System of Systems (GEOSS). Version 1 ASTER GDEM (GDEM1) was compiled from over 
1.2 million scene based DEMs covering land surfaces between 83°N and 83°S latitudes. The GDEM1 
was found to have an overall accuracy of around 20 meters at the 95% confidence level. Several 
artifacts associated with poor stereo coverage at high latitudes, cloud contamination, water masking 
issues and the stacking process used to produce the GDEM1 from individual scene-based DEMs were 
noted. A second version of the ASTER GDEM (GDEM2) was released by NASA and METI in 2011. 
Improvements in the GDEM2 result from acquiring 260,000 additional scenes to improve coverage, a 
smaller correlation kernel to yield higher spatial resolution and improved water masking. 
 
Vertical accuracy assessments included a comparison of the GDEM2 against absolute geodetic 
references over the Conterminous US (CONUS), against national elevation grids over the US and 
Japan, against the Shuttle Radar Topography Mission (SRTM) 1 arc-second elevation grids over the 
US and 20 sites around the globe, and against space borne laser altimeter data globally. Horizontal 
accuracy assessments were conducted as part of the Japan and the global SRTM studies, and 
horizontal resolution studies were conducted in both Japan and the US. The absolute vertical 
accuracy study found the GDEM2 to be within -0.20 meters on average when compared against 
18,000 geodetic control points over the CONUS, with an accuracy of 17 meters at the 95% confidence 
level. The Japan study noted the GDEM2 differed from the 10-meter national elevation grid by -0.7 
meters over bare areas, and by 7.4 meters over forested areas. Similarly, the CONUS study noted the 
GDEM2 to be about 8 meters above the 1 arc-second NED over most forested areas, and more than a 
meter below NED over bare areas. The global altimeter study found the GDEM2 to be on average 
within 3 meters of altimeter-derived control, and also documented sensitivity to tree canopy height. 
The Japan study noted that the horizontal displacement in GDEM1 of 0.95 pixels was reduced to 0.23 
pixels in GDEM2. Both teams noted improvements in horizontal resolution, between 71 and 82 
meters, comparable to the SRTM 1 arc second elevation model, but at the cost of some increased 
noise. The number of voids and artifacts noted in GDEM1 were substantially reduced in GDEM2, and 
in some areas virtually eliminated. 
 
GDEM2, while vastly improved, still contains some artifacts which could affect its utility in certain 
applications (source: http://www.jspacesystems.or.jp/ersdac/GDEM/ver2Validation/Summary_GDEM2 
_validation_report_final.pdf). 
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The original files are in GeoTIFF format (signed 16 bits) using geographic coordinates and the spatial 
resolution is 1 arc-second. Each tile is 1 by 1 degree (3601 lines by 3601 columns). Due to the fact 
that Users have to register prior to be able to obtain the data, in order to ingest the data, the User has 
to download the ASTER-GDEM tiles first to a user defined location and start the extraction procedure 
specifying the appropriate input directory on the local system used. 

3.7 MEASURES GLOBAL VI PRODUCTS V2 

VIP – Vegetation Phenology and Vegetation Index Products from Multiple Long Term Satellite Data 
Records. Kamel Didan at the University of Arizona has developed a consistent 30-year record of 
Enhanced Vegetation Index and Phenology products using the Advanced Very High Resolution 
Radiometer (AVHRR), the Systeme Pour l’Observation de la Terre (SPOT) Vegetation instrument, and 
the Moderate Resolution Imaging Spectroradiometer (MODIS) to create a 30-year record that can be 
extended into future missions (currently from 1981_001-2010_365, year_julian day). 
  
In July 2012, the VIP project released version 2 of its vegetation index products. The product suite is 
comprised of daily, 7-day, 15-day, and monthly temporal intervals covering the period start 1981 to 
end 2010. (Source: https://lpdaac.usgs.gov/user_community/nasa_measures). Resolution of the 
product is 0.05 degrees (5600 meters). Import routines for the Phenology set of products still have to 
be developed. Further information can be obtained from the documents tab at the “viplab”, available 
at: http://measures.arizona.edu/viplab_data_explorer.php#. 
 
Conventions used to calculate NDVI and EVI2 are presented below: 

NDVI (Normalized Vegetation Index):  

 

EVI2 (Enhanced Vegetation Index):  

3.8 NASA GLOBAL OCEAN DATA 

The following routines are developed to extract the data from the ocean data archive at NASA: SST 
(sea surface temperature), SSTN (night time sea surface temperature), temperature in degree C., and 
Chlor_a (chlorophyll a concentration (mg m-3). Other data ocean sets are available from there as well, 
also using other sensors. The link to the online archive is http://oceandata.sci.gsfc.nasa.gov/. 
 
The Level 3 Standard Mapped Image (SMI) products are image representations of binned data 
products. The image is typically a scaled value (16bit), two-dimensional array of an Equidistant 
Cylindrical projection of the globe. The original SMI definition was a 9.2km (at the equator) resolution 
product, resampled to 4.6 km for the products used here (source: http://oceancolor.gsfc.nasa.gov/). 
 
The long-wave SST algorithm makes use of MODIS bands 31 and 32 at 11 and 12 um. The 
brightness temperatures are derived from the observed radiances by inversion (in linear space) of the 
radiance versus blackbody temperature relationship. For msl12, these relationships were 
precomputed for the spectral response of each MODIS channel, and the tables were then stored in 
HDF files to be loaded at run-time. In modsst, the radiance versus blackbody temperature relationship 
was computed at run-time. The nonlinear SST algorithm was tuned for two different regimes based on 
brightness temperature difference. The algorithm for computing long-wave SST (sst) from observed 
brightness temperatures is shown below: 
 

dBT <= 0.5 
sst = a00 + a01*BT11 + a02*dBT*bsst + a03*dBT*(1.0/mu-1.0) 

 
dBT >= 0.9 
sst = a10 + a11*BT11 + a12*dBT*bsst + a13*dBT*(1.0/mu-1.0) 
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0.5 < dBt < 0.9 
sstlo = a00 + a01*BT11 + a02*dBT*bsst + a03*dBT*(1.0/mu-1.0) 
ssthi = a10 + a11*BT11 + a12*dBT*bsst + a13*dBT*(1.0/mu-1.0) 
sst = sstlo + (dBT-0.5)/(0.9-0.5)*(ssthi-sstlo) 

 
where: 
dBT = BT11 - BT12 
BT11 = brightness temperature at 11 um, in deg-C 
BT12 = brightness temperature at 12 um, in deg-C 
bsst = baseline SST, which is either sst4 (if valid) or sstref (from oisst) 
mu = cosine of sensor zenith angle 

 
At night, where sst4 retrieval is reliable, the algorithm uses sst4 (SST derived at 4 micron) for the bsst 
value. For daytime SST, the algorithm uses a reference SST source (sstref) for bsst, where sstref is 
operationally derived from the weekly Reynolds oisst product, bilinearly interpolated to the pixel 
location. The coefficients a00, a01, a02, and a03 and a10, a11, a12, and a13 are derived and 
continuously verified by RSMAS based on match-ups between the satellite retrievals of brightness 
temperature and field measurements of sea surface temperature. As currently implemented, these 
coefficients can be time-dependent. The coefficients are provided to msl12 through external files, 
which are in a columnated ascii format of "sensor start-date end-date ai0 ai1 ai2 ai3", with each pair of 
lines corresponding to low and high dBT difference cases, respectively.  
 
For the MODIS instrument on Terra, the retrieved long-wave SST is further augmented by a time-
dependent, mirror-side specific bias. The adjustment varies from -0.2 deg-C to 0.1 deg-C over the 
mission lifespan, and it is applied to mirror-side 1 only. The mirror-side correction was developed by 
RSMAS. Source: http://oceancolor.gsfc.nasa.gov/DOCS/modis_sst/. 
 
The Ocean Color (OC) suite of chlorophyll a (Ca, mg/m3) algorithms describe the polynomial best fits 
that relate log-transformed Ca to log-transformed ratios of remote-sensing reflectances (Rrs, 1/sr). 
 
Currently, all have the form: 

 
Ca = 10^( a0 + a1*x + a2*x^2 + a3*x^3 + a4*x^4 )  

 
where x = log10( Rrs[blue wl] / Rrs[green wl] ) 

 
 
The wavelengths and polynomial coefficients (a0...a4) used in operational MSl12 processing are 
provided below for MODIS. 
 
sensor   blue wl*  green wl   a0    a1     a2     a3       a4 
-------------------------------------------------------------------------------------------------------------------------------- 
MODIS   443>488  551   0.2830 -2.7530 1.4570   0.6590  -1.4030 
HMODIS(500-m)  469   555   0.1543 -1.9764 1.0704  -0.2327  -1.1404 
 
(* the greatest Rrs[blue wl] is used when multiple blue wl are specified)  

3.9 GLOBAL LAND DATA ASSIMILATION SYSTEM 

This Level 3 (gridded) data set’s land surface parameters, surface soil moisture, land surface (skin) 
temperature, and vegetation water content, are derived from passive microwave remote sensing data 
from the Tropical Rainfall Measuring Mission (TRMM) Microwave Imager (TMI), using the Land 
Parameter Retrieval Model (LPRM). There are two files per day, one day and one night, archived as 
two different products. The data set covers the period from December 1997 to present, at a spatial 
resolution of 0.25 degree from 40 degree north to 40 degree south, 180 degree west to 180 degree 
east. The data are stored in netCDF format. 
 
The LPRM is based on a forward radiative transfer model to retrieve surface soil moisture and 
vegetation optical depth. The land surface temperature is derived separately from TMI's Ka-band (37 
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GHz). A unique feature of this method is that it can be applied at any microwave frequency, making it 
very suitable to exploit all the available passive microwave data from various satellites.  
 
Input data are from the TMI Brightness Temperatures (1B-11) product, daytime and night time passes 
and processed using LPRM (source: http://disc.sci.gsfc.nasa.gov/hydrology/data-holdings/). 
 
Here the Surface Soil Moisture and the Skin Temperature are retrieved. Skin temperature refers to the 
effective radiating temperature of the soil plus canopy surface. It is inferred from satellites in the 8-12 
um window region. In climate models, it is the temperature used to determine upward thermal 
emission. The skin temperature usually shows a larger diurnal variation than the surface air 
temperature, a factor that needs to be considered when evaluating data/model comparisons (source: 
R. E. Dickinson.Land surface. In K. E. Trenberth, editor, Climate System Modeling, pages149-171. 
Cambridge Univ. Press, 1992]. The SSM is expressed as volumetric soil moisture (volume of water in 
relation to total volume – soil volume + water volume + air space). 
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3.10 WEB MAPPING SERVICES 

 MPE and RFS to Google 3.10.1

These two services make use of the 15 minutes precipitation products, the MPE derived from MSG 
and the RFS derived from GOES. The Multi-Sensor Precipitation Estimate (MPE) product consists of 
the near-real-time rain rates in mm/hr for each METEOSAT image in original pixel resolution. The 
algorithm is based on the combination of polar orbiter microwave measurements and images of the 
Meteosat IR channel by a so-called blending technique. The MPE is most suitable for convective 
precipitation. The RFS product comprises the instantaneous and the accumulated convective rainfall 
estimates, based on GOES images, for the South America region. The estimation is based on the 
adjusted hydro-estimator methodology from South America, using INPE information about precipitated 
water, relative humidity and winds.  At ITC these 15 minutes products are aggregated to obtain the 24 
hr precipitation (from 00:00 to 23:45 UTC). These files (in ILWIS format) are compressed and 
subsequently transferred to FTP (ftp://ftp.itc.nl/pub/mpe/). After specifying an output directory the 
application can be started, the accumulated 24 hr precipitation map is downloaded, decompressed 
and transformed into a PNG format (with a transparent layer for the areas that have not received 
precipitation). A “KML” file is created and executed which invokes Google Earth to start and display 
the results. These applications assume that Google Earth is locally available. It has been noted 
recently that Google Earth shows some strange behaviour when displaying the map overlay  of the 
MSG based MPE using Window-7. 
 
At any given day the aggregated rainfall from the previous day is processed; for the MPE product at 
08:00 UTC and for the RFS product at 11:00 UTC. Daily aggregated data is available from the FTP 
location provided above approximately half an hour and 10 minutes later for the MPE and RFS 
products respectively. 

 Surface Pressure Forecast Europe 3.10.2

This application automatically downloads the surface pressure forecast over Europe prepared by the 
UK Met-Office. New forecasts become available at 07:30 UTC. Forecasts are downloaded and 
visualized using IrfanView as an animation with maps showing the surface pressure from T+0 to T+84. 
Further information can be obtained from: http://www.metoffice.gov.uk/weather/europe/surface_ 
pressure.html, like the description of the weather chart symbols used. 

 Current Position of the Africa ITF 3.10.3

This application automatically downloads the latest image showing the current position of the Inter 
Tropical Convergence Zone (ITCZ), also called the Inter Tropical Front, produced by NOAA, available 
from: http://www.cpc.noaa.gov/products/fews/ITCZ. Data is available, updated on a decadal basis, 
when the ITCZ is situated over the Northern Hemisphere. IrfanView is used to display the downloaded 
image. By pressing the escape key the visualization is aborted.  

 NOAA Weather Charts 3.10.4

The NWS Gateway provides access to the latest version of the weather facsimile chart they 
operationally distribute. The charts are not altered or enhanced and are in the original black-and-white 
form used by NWS offices, available from: ftp://tgftp.nws.noaa.gov/fax/. The utilities provided 
download and animate, using IrfanView, the NOAA weather charts for the Northern Hemisphere, 
Europe and Africa, Africa and Asia and Latin America and Africa, showing the forecast up to 36 hours. 
  
The Flight level selected is FL050, meaning the situation at 5000 feet, or at a standardized barometric 
pressure of 850 millibar (roughly 33 feet per millibar, 1013.25-850=163.25 millibar * 33feet = 5387.25 
feet * 0.304=1637 meter). Note that this assumes standard pressure (1013.25 mb at sea level - using 
standard datum) and does not include local topography! It is the lowest level provided and in many 
cases corresponds to the ground surface phenomena (temperature and wind speed - direction). See 
also figure 3.10.1 for the wind speed symbols used and conversions from knots to miles/hour and to 
meters/second (source: http://www.theweatherprediction.com/basic/conversions/). 
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Figure 3.10.1: Wind speed and direction symbols and wind speed conversions 
 

On analysis charts and weather reporting observations, wind is most 
commonly given in one of three units: Miles per hour, knots, or meters per 
second. To find miles per hour, multiple the knots value by 1.15. To find 
knots, divide the miles per hour value by 1.15. 
 
1 knot = 1.15 miles per hour 
1 mile per hour = 0.87 knots 
100 knots = 115 mph 
 
Metric unit wind speeds are often expressed as meters per second. The 
conversion below shows the change from miles per hour to meters per 
second. 
 
(1 mi/hr)*(1 hour/3,600 sec)*(1.61 km/1 mile)*(1000 meters/1 km) = 0.45 
m/s 
 

 

 NOAA-CPC SST and SST Anomaly 3.10.5

To get some idea with respect to the possible occurrence of El Niño – Southern Oscillation (ENSO) an 
SST and SST Anomaly animation can be retrieved from the Climate Prediction Centre. More 
information is available at: http://www.cpc.ncep.noaa.gov/products/precip/CWlink/MJO/enso.shtml. 
 
The ENSO cycle refers to the coherent and sometimes very strong year-to-year variations in sea- 
surface temperatures, convective rainfall, surface air pressure, and atmospheric circulation that occur 
across the equatorial Pacific Ocean. El Niño and La Niña represent opposite extremes in the ENSO 
cycle. El Niño refers to the above-average sea-surface temperatures that periodically develop across 
the east-central equatorial Pacific. It represents the warm phase of the ENSO cycle, and is sometimes 
referred to as a Pacific warm episode. La Niña refers to the periodic cooling of sea-surface 
temperatures across the east-central equatorial Pacific. It represents the cold phase of the ENSO 
cycle, and is sometimes referred to as a Pacific cold episode. The animation shows the SST (and 
anomaly) conditions over the 12 weeks before present. 

 ECMWF Re-Analysis data 3.10.6

The European Centre for Medium-Range Weather Forecasts has made available the ERA-Interim. 
ERA-Interim is the latest ECMWF global atmospheric reanalysis of the period 1979-01-01 to present. 
Reanalyses of multi-decadal series of past observations have become an important and widely utilized 
resource for the study of atmospheric and oceanic processes and predictability. Since reanalyses are 
produced using fixed, modern versions of the data assimilation systems developed for numerical 
weather prediction, they are more suitable than operational analyses for use in studies of long-term 
variability in climate. Reanalysis products are used increasingly in many fields that require an 
observational record of the state of either the atmosphere or its underlying land and ocean surfaces 
(source: http://www.ecmwf.int/research/era/do/get/ Reanalysis_ECMWF). ERA-Interim data can now 
be downloaded from the internet at full resolution from http://data-portal.ecmwf.int/data/d/ 
interim_full_daily. A large number of parameters can be retrieved from here and can be quickly 
visualized using the “Panoply” utility, including preparation of animated sequences. 
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4. PRACTICAL EXERCISES USING THE ISOD TOOLBOX 

4.1 ONLINE CLIMATIC DATA RETRIEVAL 

 Introduction 4.1.1

After installation of ILWIS and the ISOD Toolbox (version 1.0), start ILWIS and open the “ISOD” > 
“Toolbox” options from the left hand menu tree. Inspect the menu strings of the Toolbox and open the 
item “Configuration” > “Folders”. Note that here the assumption is made that you have created on your 
local system, using drive “C”, a directory called “InSitu”. For the Folder items under CPC_gauge, 
GSOD, GTS, TAF, specify the appropriate directory and press “Save” to store the drive:\directory 
settings. Close the Toolbox and use the ILWIS Navigator to move to the directory “C:\InSitu”. Close 
ILWIS and start ILWIS again, ensure that the location of your catalogue is now “C:\InSitu”. Select from 
the menu the “ISOD” and “Toolbox” options and you are ready to start the exercises. Note that if you 
have changed working directory during an active ILWIS session, it is advised to close ILWIS and start 
it again. The catalogue should now open in the correct working directory. Also note the other “golden 
rules” when working with ILWIS (see also Chapter 1.2) 

 Global Surface Summary of Day Data (GSOD) 4.1.2

Within the ISOD toolbox utilities are available to incorporate the archive maintained and updated by 
the NCDC, providing a global surface summary of daily data on various climatological parameters as 
indicated in Chapter 3.2.1. First a map will be visualized showing the locations and the station 
numbers of the climatological stations (over 27750 records).  
 
From the “ISOD” and “Toolbox” main menu select the “Online InSitu Climate Database” > “NCDC 
Integrated Surface Data (ISD)” > “Stations map of Global surface summary of day product produced 
by the NCDC” sub menu. Note that the “Output Directory” here is “C:\InSitu” and press “Import”. 
 
After import a map view will be shown, indicating the locations of the stations. Moving the mouse over 
the active map window, keeping the left mouse button pressed is providing information on the station 
number. To get additional information, select from the menu of the active map window the option “File” 
and “Open Pixel Information”. Zoom into the area of interest and move the mouse over a station. In 
the Pixel Information window additional details are shown, such as station name, USAF number, 
coordinates and elevation. The USAF number should be noted as this is used during the subsequent 
extraction of the daily summary data. Furthermore note that the record “CALL” provides the ICAO 
Code, which will also be used in one of the next exercises (chapter 4.1.4: TAF import). 
 

Figure 4.1.1: GSOD station locations and the pixel information window 

 
To extract the station data, from the “ISOD” and “Toolbox” main menu select the “Online InSitu 
Climate Database” > “NCDC Integrated Surface Data (ISD)” > “Import GSOD station data” sub menu. 
Specify the “Year”, USAF “Station”, check the settings for the “Output Directory” and press “Import”. 
Here use is made of the station “Twenthe”, year is “2009” and USAF station number is “062900”.  Note 
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that a 6 digit station code is required; in case the station has only a 5 digit code (like in the example 
presented here) the station number coding should always precede with a zero (0).  
 
Additional information on the data is provided when selecting the “Metadata” option. Note that this file 
is retrieved from your ILWIS sub-directory “\Extensions\ISOD-Toolbox\util\metadata”. When using the 
import routine the data will be extracted and processed, additional columns are calculated providing 
the data in SI units, like temperature (also minimum and maximum), dew point, visibility, wind speed 
and maximum wind speed, precipitation. Note that if during import an error message appear that 
ILWIS cannot find table, close ILWIS, start ILWIS again and repeat the import. This error occurs due 
to the fact that you changed to another output directory during an active ILWIS session. 
 
To visualize the imported station data, open the imported table, starting with “st_USAFno_year”, in this 
case “st_062900_2009”. Inspect the table content. In the menu of the active table window, select the 
graph icon, in the subsequent popup window, don’t select an X-axis, for the Y-axis select the attribute 
to be visualized, here “Prcp_mm” and press “OK”. 
 
Now from the left hand graph menu the visualization properties can be changed. Double click the layer 
“Prcp_mm”. In the Graph options, change the name to “Precipitation”, select a “Needle” 
representation, instead of a point, and eventually change the colour to “Blue” and press “OK”. 
 
Now select from the graph menu the option “Edit” > “Add Graph” > “from Columns” and select for the 
Y-Axis the table attribute “TempMIN_C” and press “OK”. Double click the layer “TempMIN_C”. In the 
Graph options, change the name to “Min Temperature”, select a “Line” representation, instead of a 
point, and eventually change the colour to “Magenta”. Now select “Use Y-Axis” the “Right” Axis, 
unselect the option “Show Grid” and press “OK”. 
 
From the graph menu, select the option “Y-Axis Right” , as Axis Text “Temperature” and set the Min-
Max Interval to “-25” and “40” respectively and press “OK”. Note that the data range required can be 
obtained from the statistics pane from the (bottom) of the table! 
 
Repeat the procedure for the attribute “tempMAX_C” and “Dewp_C”, call these “Max Temperature” 
and “Dewpoint Temperature” respectively, select as representation “line” and select appropriate 
colours. Ensure that the Y-Axis Right is used! In the graph window itself the title can be modified. 
Double click on the title in the Graph and consult figure 4.1.2 for a sample title.  
 

Figure 4.1.2: Precipitation and temperature for Twenthe (2009), USAF station number 062900 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
As additional exercise you can repeat above described procedure using a station / year of your 
preference. 
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 GTS station data on precipitation and temperature 4.1.3

Within the ISOD toolbox utilities are available to incorporate the rolling yearly GTS archive maintained 
by NOAA/CPC. To extract the station data, from the “ISOD” and “Toolbox” main menu select the 
“Online InSitu Climate Database” > "NOAA CPC-FEWS GTS daily data" > "Import global GTS station 
data" sub menu. Specify the “Date” stamp in the required format (yyyymmdd), here “20111201” is 
used, note the “Output Directory” and press “Import”. 
 
Select from the catalogue the table “gts_20111201” and inspect the content. Note that typically over 
8000 stations are available. Close the table. From the catalogue, right click with the mouse on the 
table “gts_20111201” and from the context sensitive menu select the option “Table operations” > 
“Table to Pointmap”. From the table to point map menu, specify as Coordinate System 
“LatLonWGS84” and as output map “gts_20111201”. Press “Show” to create the point map. In the 
Display Options – Point Map click the “Symbol” button and as Size, specify “3” and as fill colour select 
“Red” and press “OK” twice. From the active point map display window select the option “Add Data 
Layer” and browse to your ILWIS directory, select the polygon map “Country_02” from the 
subdirectory “Extensions\ISOD-Toolbox\util\maps”. As display option unselect the item “Info” and 
specify the option “Boundaries Only”. Press “OK” to display the map. Your results should resemble 
those of figure 4.1.3 and note the distribution of the stations. 
 

Figure 4.1.3: GTS stations for 20111201

 
 
From the ILWIS main menu select the option “File” > “Create” > “Georeference”. Specify the settings 
as given in figure 4.1.4 (left) and press “OK” to create the Georeference. Frome the main ILWIS menu 
select the option “Operations” > “Interpolation” > “Point Interpolation” > “Moving Average”. As Point 
map select from the point map “gts_20111201” the table attribute “Prcp_mm” (press the + sign in front 
of the point map name to see the various table attributes!!), select the Georeference “gts_sub”, use 
other settings as given by their default and press “Show”. See also right hand picture of figure 4.1.4.  
 
Upon completion of the interpolation display the map and check your results obtained. Use as 
Representation “mpe_single”. To add the country boundaries to the map display, select the option 
“Layers” > “Add Layer” and select the polygon map “Country_02”. As display option unselect the item 
“Info” and specify the option “Boundaries Only”. Press “OK” to display the map. Also add the 
“gts_20111201” point map to the active map display. In the Display Options – Point Map click the 
“Symbol” button and as Size, specify “3” and as fill colour select “Red” and press “OK” twice.  
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Figure 4.1.4: Georeference details and moving average parameter settings 

 
Note that there are hardly measurements from the sea and ocean surface. To obtain the rainfall only 
over the land use can be made of the polygon map “country_02”. Select from the main ILWIS menu 
the option “Operations” > “Rasterize” > “Polygon to Raster”. As Polygon map use “country_02”, as 
output raster map specify “country_euro” and as Georeference select “gts_sub”. Press “Show” to 
conduct the operation. Have a look at the (“values”!!! of the) map obtained. 
 
To retrieve only the rainfall over land from the raster map “gts_20111201”, type the following 
expression in the command line of the main ILWIS menu: 
 

p_fin20111201:=ifnotundef(country_euro,gts_20111201) 
 
Keep the other settings default and press “OK” to execute the operation. Use as Representation 
“mpe_single”. Add the country boundaries and gts station locations as well. Your results should 
resemble those of figure 4.1.5. From the active map display window select “File” > “Open Pixel 
Information”. Move the cursor over the map and check the results obtained using the pixel information 
table and check the interpolation results against the gts input data. 
 

Figure 4.1.5: Resulting interpolated rainfall map of 20111201 using GTS station input 

 
As additional exercise repeat above described procedure and use the minimum or maximum 
temperature as provided by GTS daily data. Use the same geographical window and same 
interpolation procedure. Furthermore you can specify another geographic window by creating another 
georeference and retrieve the rainfall for this newly defined region; eventually specify another date. 
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 Current Weather Conditions using Terminal Aerodrome Forecast (TAF) data 4.1.4

From the “ISOD” and “Toolbox” menu, select the following options: “Online InSitu Climate Databases” 
> “Current Weather Conditions from TAF” > “Terminal Aerodrome Forecast station data” and press the 
option “Load code file” and try to find the appropriate ICAO code. Type “Amsterdam” in the second 
“Key” field (case sensitive!) and note the code for Amsterdam/Schiphol. Enter the ICAO code (here 
“EHAM”, again Case Sensitive) for the “CODE” stamp and press “Import”.  
 
The report is showing the Current Weather Conditions and a summary of the last 24 hours for 
Amsterdam Airport Schiphol, Netherlands. This document is stored on your output “drive:\directory” as 
well (using airport code and time format given as: “ICAOcode_yyyymmddhhmm.html”). The time 
format is obtained from the time settings of your system when extracting the file. If you are interested 
in obtaining regular information from certain stations you can create a “Scheduled Task” in the 
Operating System to automate the extraction procedure!  
 
Close the ICAO html report retrieved. Use the “Windows” Explorer and check the content of your 
working directory and open the file: “EHAM_ yyyymmddhhmm.html” and check once more the content 
of the report. 
 
Select from the Code File table another country or airport, e.g. Cape Town, South Africa (“FACT”) and 
repeat the procedure to extract the TAF data. 
 
Note: For the code file use is made of the document “Location Indicators by State” 
(r4cdlocationindicatorsbystate.pdf), available from http://legacy.icao.int/anb/aig/taxonomy/r4cdlocation 
indicatorsbystate.pdf, which is providing all ICAO codes. The Toolbox Code File table is stored under 
the main ILWIS directory “\Extensions\ISOD-Toolbox\util\metadata”. This file only provides the ICAO 
code per city / country. For presenting the html file currently Windows Internet Explorer is used. 
Furthermore the system regional setting format assumed is “English (United States)”, as short date 
format “M/d/yyyy” and short time format “h:mm tt” are expected. If you use another default web 
browser or your system uses different “Region and Language” settings the results might appear 
different! 

4.2 GAUGE BASED AND SATELLITE DERIVED RAINFALL DATA 

 Introduction 4.2.1

Routines have been developed to integrate the online (satellite derived) precipitation products from the 
NOAA Climate Prediction Centre, EUMETSAT, NASA and FEWS NET RFE for Africa. A number of 
exercises are presented below on the various products that can be retrieved. In the ISOD Toolbox, 
version 1.1, various import routines have been created to retrieve some online precipitation resources. 
Routines are available to import global precipitation products like CPC gauge based analysis of global 
daily precipitation, Cmorph, Qmorph, TRMM, latest rainfall from the EUMETSAT as well as RFE 
version 1 and 2 rainfall products for Africa and climatology, produced by FEWS-NET and TAMSAT.  
 
After installation of ILWIS and the ISOD Toolbox (version 1.0), start ILWIS and open the “ISOD” > 
“Toolbox” options from the left hand Operation-Tree (see also figure 2.1). Inspect the menu items of 
the Toolbox and open the item “Configuration” > “Folders”. Note that here the assumption is made that 
you have created on your local system, using drive “C”, a directory called “Sat_Precip”. For the Folder 
items under CPC_gauge, Cmorph, FEWS_RFE, MPEdirect, Qmorph, TAMSAT_archive, TRMM_3B42 
and TRMM specify the appropriate directory and press “Save” to store the output drive:\directory 
settings. Use the ILWIS Navigator to move to the specific working directory. 

 CPC unified Gauge-Based analysis of Global Daily Precipitation 4.2.2

Within the ISOD toolbox utilities are available to incorporate the CPC unified Gauge-Based analysis of 
Global Daily Precipitation. To extract retrospective version global interpolated precipitation data, from 
the “ISOD” and “Toolbox” main menu select the “Gauge – Satellite derived Rainfall Data” > “Global 
Rainfall” > "CPC Gauge-Based Analysis of Global Daily Precipitation" > "Retrospective version daily 
data - 0.5 degree" sub menu.  This option allows import of daily interpolated gauge based precipitation 
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from 1979 to 2005. Specify the “Date” stamp in the required format (yyyymmdd), here “19791201” is 
used, note the “Output Directory” and press “Import”. 
 
Upon completion of the import, display the map “CPC_Pgauge_19791201” using as Representation 
“MPE_sum”. Add the country boundaries, unchecking the display option “Info” and activating the 
option “Boundaries only”. Your results should resemble those of figure 4.2.1. 
 

Figure 4.2.1: CPC unified Gauge-Based Global Daily Precipitation of 19791201 

 
To extract the recent real-time version global interpolated precipitation data, from the “ISOD” and 
“Toolbox” main menu select the “Gauge – Satellite derived Rainfall Data” > “Global Rainfall” > > "CPC 
Gauge-Based Analysis of Global Daily Precipitation" > "Real-time version daily data - 0.5 degree 
20090101" sub menu. This option allows import of daily interpolated gauge based precipitation starting 
from 2009. Specify the “Date” stamp in the required format (yyyymmdd), here “20111201” is used, 
note the “Output Directory” and press “Import”. Note that the data for the intermediate period 
(20060101-20081231) can be retrieved using the toolbox option “Real-time version daily data - 0.5 
degree 2006 to 2008”. Upon completion of the import, display the map “CPC_Pgauge_20111201” 
using as representation “MPE_sum”. Add the country boundaries, unchecking the display option “Info” 
and activating the option “Boundaries only”. Your results should resemble those of figure 4.2.2. 
 

Figure 4.2.2: CPC unified Gauge-Based Global Daily Precipitation of 20111201 
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 NOAA CPC, NASA, EUMETSAT, FEWS NET and TAMSAT online precipitation products 4.2.3

Various satellite derived rainfall products and time series are available online. Open the “ISOD” > 
“Toolbox” options from the left hand menu tree and open the item “Configuration” > “Folders”. Note 
that here the assumption is made that you have created on your local system, using drive “C”, a 
directory called “Sat_Precip”. For the Folder items under Cmorph, FEWS_RFE, Qmorph, 
TRMM_3B42, TRMM, MPEdirect and TAMSAT_archive specify the appropriate output directory and 
press “Save” to store the drive:\directory settings. If you started from chapter 4.2 the settings are 
already specified. Move to the working directory using the ILWIS Navigator. Close ILWIS and open it 
again, remember the “golden rules” as indicated in Chapter 1.2. 

4.2.3.1 CMORPH 

From the “ISOD” > “Toolbox” main menu select the “Gauge – Satellite derived Rainfall Data” > “Global 
Rainfall” > > “CMORPH – Global” > “CMORPH 8 km - 30 min” sub menu. In this case only the “Date” 
field and the “Output Directory” need to be specified. Enter a suitable date which is more recent than 
two weeks as the data is extracted from a rolling archive of about two weeks up to present. Upon 
completion of the import two files are available, the “cmorph8km30min_yyyymmddhhlater” map 
represents the next half hour after the time stamp and the “cmorph8km30min_yyyymmddhhbefore” is 
the previous half hour precipitation with regard to the time stamp. The unit is in mm/hr. Display both 
maps, using as representation “mpe_single” , add the country boundaries (no Info, boundaries only) 
and using the mouse with the left button pressed inspect the map values.  
 
The CMORPH 0.25 degree – 3 hours product can be obtained from the ftp.cpc.ncep.noaa.gov server 
in the precip/global_CMORPH/3-hourly_025deg directory and all units are mm/hr. Data is available 
from 7 December 2002 onwards. From the “ISOD” > “Toolbox” main menu select the “Gauge – 
Satellite derived Rainfall Data” > “Global Rainfall” > “CMORPH – Global” > “CMORPH 0.25 degree - 3 
hour” sub menu. In this case only the “Date” field and the “Output Directory” need to be specified. As 
Date stamp select “20111001” and press “Import”. For the specified day 8 three hour precipitation 
maps are imported. 
 
Select from the main ILWIS menu “File” > “Create” > “Map List”, as Map List name enter 
“Cmorph_3hr”, select all cmorph025d3hr_yyyymmdd_hhUTC” maps (8 in total) in the left hand maplist 
window (selected maps are indicated by a blue colour), press the “>” sign to add them to the right 
hand Create MapList window and press “OK” to save the new maplist. Double click with the mouse the 
newly created Maplist “Cmorph_3hr”. In the MapList window select as display option “Open as Slide 
Show”, as Representation select “mpe_single” and press “OK” twice, add the country boundaries (no 
Info, boundaries only) and using the mouse with the left button pressed inspect the map values.  
 
Close the maplist “Cmorph_3hr” window, click with the right mouse button pressed on the map list icon 
“Cmorph_3hr” and select from the context sensitive menu the options  “Statistics” > “MapList 
Statistics” , as statistical function select “Sum” and as Output Raster map specify “cmorph_sum” and 
press “Show”. Display the map using as Representation “mpe_sum”. Add the country boundaries (no 
Info, boundaries only) and using the mouse with the left button pressed, inspect the map values. Note 
that the initial map values are in mm/hr and the time step is 3 hours. To get the total 24 hr precipitation 
this map still has to be multiplied by a factor of 3 as the initial unit is in mm/hr! Type the following 
expression in the command line of the main ILWIS menu: 
 
  cmorph_sum_mm_day:=cmorph_sum*3  
 
Keep all other settings as indicated by their defaults, press “OK” to execute the computation. Add this 
map to the existing display and select from the active map display window menu the option “File” > 
“Open Pixel Information”. Move the mouse cursor over the map and inspect the values.  
 
Leave the map display window open and now from the “ISOD” > “Toolbox” main menu select the 
“Gauge – Satellite derived Rainfall Data” > “Global Rainfall” > “CMORPH – Global” > “CMORPH 0.25 
degree - daily” sub menu. In this case only the “Date” field and the “Output Directory” need to be 
specified. As Date stamp select “20111001” and press “Import”. For the specified day the 24 hour 
precipitation map is imported. Add this map, “cmorph_d20111001”, to your active map display (using 
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as Representation “mpe_sum”) and use pixel information once more to inspect the values. Close the 
map display window (s). 
 
Finally import the weekly precipitation map; totalled across the week ending on the date as given by 
the file name. From the “ISOD” > “Toolbox” main menu select the “Gauge – Satellite derived Rainfall 
Data” > “Global Rainfall” > “CMORPH – Global” > “CMORPH 0.25 degree -weekly” sub menu. In this 
case only the “Date” field and the “Output Directory” need to be specified. As Date stamp select 
“20111001” and press “Import”. Display the imported map “cmorph_w20110101”. Note that the date in 
the file name represents the final day of the week long time period, using 00:00 UTC as the starting 
and ending times. 

4.2.3.2 QMORPH 

From the “ISOD” > “Toolbox” main menu select the “Gauge – Satellite derived Rainfall Data” > “Global 
Rainfall” > “QMORPH – Global” > “QMORPH 8 km 30 min” sub menu. In this case only the “Date” field 
and the “Output Directory” need to be specified. Enter a suitable date which is more recent than one 
week as the data is extracted from a rolling archive of about two weeks. Upon completion of the import 
two files are available, the “qmorph8km30min_yyyymmddhhlater” map represents the next half hour 
after the time stamp and the “qmorph8km30min_yyyymmddhhbefore” is the previous half hour 
precipitation with regard to the time stamp. The unit is in mm/hr. Display both maps, using as 
Representation “mpe_single”, add the country boundaries (no Info, boundaries only) and using the 
mouse with the left button pressed inspect the map values.  

4.2.3.3 TRMM 

To import the daily global precipitation data select from the “ISOD” > “Toolbox” main menu the “Gauge 
– Satellite derived Rainfall Data” > “Global Rainfall” > “TRMM – Global” > “TRMM 0.25 degree - daily” 
sub menu. In this case only the “Date” field and the “Output Directory” need to be specified. As Date 
stamp select “20111001” and press “Import”. For the specified day the 24 hour precipitation map is 
imported. Display this map, “trmm_20111001”, using as Representation “mpe_sum”, add the country 
boundaries (no Info, boundaries only) and use pixel information to inspect the values. Note the regions 
between 50-60 degree north and south latitudes, these do not contain valid data! 
 
Now import the data from the TRMM 3B42 day archive from the “ISOD” > “Toolbox” main menu, select 
the item “Gauge – Satellite derived Rainfall Data” > “Global Rainfall” > “TRMM – Global” > “TRMM 
3B42 day archive” sub menu. In this case only the “Date” field and the “Output Directory” need to be 
specified. As Date stamp select “20111015” and press “Import”.  During import all 3 hour events are 
extracted and processed, a map list is created and an aggregate statistics function “sum” is executed, 
resulting in the daily total precipitation map. Note that the 3 hour events are given in mm/hr and the 
day sum map is given in mm/day! 
 
Display the imported maplist “trmm_3B42_20111015” as an animated sequence, Double click on the 
map list and in the MapList window select as display option “Open as Slide Show”,  as representation 
select “mpe_single”, add the country boundaries (no Info, boundaries only) and using the mouse with 
the left button pressed inspect the map values. Display also the imported map 
“trmm_3B42_20111015_day” using as representation “mpe_sum”. From the map window showing the 
map “trmm_3B42_20111015” select from the menu “File” > “Open Pixel Information”. From the Pixel 
Information menu select “File” > “Add Map” and now select the map list “trmm_3B42_20111015” and 
press “OK”. Move the mouse over the map display and check the resulting values. Once more note 
that the 3 hour rainfall events are giving the rainfall intensity in mm/hr.  

4.2.3.4 MPE 

Select “ISOD” > “Toolbox” > “Gauge – Satellite derived Rainfall Data” > “Latest 24 hr MPE from 
EUMETSAT” > “MPE MSG based”.  Note the output directory and press “Import”. The latest 96 rainfall 
products are retrieved from the EUMETSAT website and are imported in ILWIS. The files are retrieved 
from an online EUMETSAT website, located at: http://oiswww.eumetsat.org/SDDI/html/grib.html. The 
data provided there is deleted after 24 hours. This routine needs a fast internet connection as a lot of 
files are transferred (96 from MSG, one file for each 15 minutes interval). Rainfall intensities are given 
in mm per hour per time interval. 
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After the import of all 96 images has been completed, select from the main ILWIS menu “File” > 
“Create” > “Map List”, as Map List name enter “MPE_recent”, select all msgmpeyyyymmddhhmm 
maps (96 in total) in the left hand maplist window (selected maps are now indicated by a blue colour), 
press the “>” sign to add them to the right hand Create MapList window and press “OK” to save the 
new maplist. Double click with the mouse the newly created Maplist “MPE_recent”. In the MapList 
window select as display option “Open as Slide Show”, as Representation select “mpe_single” and 
press “OK” twice, add the country boundaries (no Info, boundaries only) and using the mouse with the 
left button pressed, inspect the map values.  
 
Eventually import also the MPE derived from Meteosat-7 and repeat the procedure as indicated 
above, note that the temporal resolution of MET-7 is half hourly, therefore 48 files are retrieved and 
processed. Here also the rainfall is in mm/hr per instance. 

4.2.3.5 Africa Rainfall Estimate (RFE) and Climatology Version 2 (ARC2)  

To import the RFE version1 10 day satellite derived precipitation estimates, select from the “ISOD” > 
“Toolbox” main menu the “Gauge – Satellite derived Rainfall Data” > “FEWSNET Rainfall - 
Climatology Africa” > “Rainfall RFE – Africa” > “RFE version1 10 day estimates” sub menu. In this 
case only the “Date” field and the “Output Directory” need to be specified. As Date stamp select 
“1999121” and press “Import”. For the specified dekade the precipitation map is imported. Display the 
map, “rfe1_1999121” using as Representation “rfe-dec”, add the country boundaries (no Info, 
boundaries only) and use pixel information to inspect the values.  
 
Now import the daily and dekadal RFE Version2 precipitation maps; from the “ISOD” > “Toolbox” main 
menu first select the “Gauge – Satellite derived Rainfall Data” > “FEWSNET Rainfall - Climatology 
Africa” > “Rainfall RFE – Africa” > “RFE version2 daily estimates” sub menu. In this case only the 
“Date” field and the “Output Directory” need to be specified. As Date stamp select “20101031” and 
press “Import”.   
 
Repeat the procedure using as Date stamp “2010103, now using the menu option “RFE version2 10 
day estimates”. Display the two imported maps, “rfe2_20101031”, using as Representation 
“mpe_sum” and “rfe2_2010103”, using as Representation “rfe_dec”. Add the country boundaries (no 
Info, boundaries only) and use pixel information to inspect the values. Also note the difference in 
geographical extent between the RFE1 and RFE2 versions. 
 
To derive appropriate rainfall climatology the procedure as described above can be applied. Recently 
the ARC2 data set became available, providing the mean monthly, dekadal and daily precipitation, 
currently derived from rainfall estimates of 1983 up to 2011.To import the monthly ARC2 data select 
from the “ISOD” > “Toolbox” main menu the “Gauge – Satellite derived Rainfall Data” > “FEWSNET 
Rainfall - Climatology Africa” > “RFE ARC2 – Climatology Africa” > “RFE monthly mean climatology” 
sub menu. In this case only “Output Directory” needs to be specified and press “Import”.   
 
After the data has been retrieved and imported using a looping procedure, click with the mouse on the 
ILWIS catalogue and press “F5” or select from the ILWIS main menu “Window” > “Refresh”. Now 
create a maplist of the 12 newly created RFE mean dekadal rainfall maps (rfe_clim_month01 to 
rfe_clim_month12) and show this as an animation. Select from the main ILWIS menu “File” > “Create” 
> “Map List”, as Map List name enter “RFE_clim_month”, select all “rfe_clim_month” maps (12 in total) 
in the left hand maplist window (selected maps are indicated by a blue colour), press the “>” sign to 
add them to the right hand Create MapList window and press “OK” to save the new maplist. Double 
click with the mouse the newly created Maplist “RFE_clim_month”. In the MapList window select as 
display option “Open as Slide Show”, as Representation select “rfe_month” and press “OK” twice, add 
the country boundaries (no Info, boundaries only) and using the mouse with the left button pressed 
inspect the map values. Note the temporal change of the rainfall patterns over Africa. 
 
Repeat the procedure but now process the dekadal ARC2 rainfall maps.  Select from the “ISOD” > 
“Toolbox” main menu the “Gauge – Satellite derived Rainfall Data” > “FEWSNET Rainfall - 
Climatology Africa” > “RFE ARC2 – Climatology Africa” > “RFE dekadal mean climatology” sub menu. 
In this case only “Output Directory” needs to be specified and press “Import”.   
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After the data has been retrieved and imported, click with the mouse on the ILWIS catalogue and 
press “F5” or select from the ILWIS main menu “Window” > “Refresh”. The name convention used for 
the output files created is “rfe_clim_dekad011” to “rfe_clim_dekad123”. Now create a maplist of the 36 
imported RFE mean dekadal rainfall maps and show this as an animation, using the procedure as 
described above. Display the maps using as Representation “rfe_dek”. Add the country boundaries 
(no Info, boundaries only) and use pixel information to inspect the values. 
 
In a similar manner also the daily mean ARC2 rainfall data can be retrieved and processed. Note that 
365 days (excluding 29 February) are available when the routine has completed the processing. To 
conduct this routine select from the “ISOD” > “Toolbox” main menu the “Gauge – Satellite derived 
Rainfall Data” > “FEWSNET Rainfall - Climatology Africa” > “RFE ARC2 – Climatology Africa” > “RFE 
daily mean climatology” sub menu. In this case only “Output Directory” needs to be specified and 
press “Import”.  Note that given the large number of files the routine takes some time! The name 
convention used for the output files created is “rfe_clim_day0101” to “rfe_clim_day1231”. 

4.2.3.6 TAMSAT 

Dekadal (every 10 days) and monthly rainfall estimates and anomalies derived from Meteosat Thermal 
Infra-Red (TIR) channels are based on the recognition of storm clouds and calibration against ground-
based rain gauge data. This rainfall estimate is produced by the University of Reading, Meteorology 
Department, UK. 
 
A number of products are available, like the dekadal and monthly accumulated rainfall products for 
Africa, the dekadal and monthly accumulated rainfall anomaly products for Africa. Select “ISOD” > 
“Toolbox” > “Gauge – Satellite derived Rainfall Data” > “TAMSAT Rainfall archive - Africa” > “Dekadal 
Rainfall” > “Dekadal Rainfall from 1983 onwards”.  As date stamp specify: “2011101”. Upon 
completion of the import display the map “rfe2011101” and as Representation use “rfe_dec”. Add the 
country boundaries (no Info, boundaries only) and using the mouse with the left button pressed note 
the map values.  
 
To import the monthly accumulated rainfall map of October 2011, select the menu options “Gauge – 
Satellite derived Rainfall Data” > “TAMSAT Rainfall archive - Africa” > “Monthly Rainfall” > “Monthly 
Rainfall from 1983 onwards” and specify as date stamp “201110”. Upon completion of the import 
display the map “rfe201110” and as Representation use “rfe_month”. Add the country boundaries (no 
Info, boundaries only) and using the mouse with the left button pressed inspect the map values. 
 
Also import the 10 day and monthly rainfall anomalies for October 2011 and use as Representations 
“rfe_anom_dec” and “rfe_anom_month” for the imported “rfe2011101_anom” and “rfe_201110_anom” 
maps respectively. Add the country boundaries (no Info, boundaries only) and using the mouse with 
the left button pressed, inspect the map values. 
 
To get an idea of the distribution of the rainfall over a longer time period the rainfall climatology 
(derived from 2000-2009) can be used, but you can also compare your actual rainfall against the 
rainfall climatology. To import the Dekadal Climatology rainfall, select the menu options “Gauge – 
Satellite derived Rainfall Data” > “TAMSAT Rainfall archive - Africa” > “Rainfall Climatology” > 
“Dekadal rainfall 2000-2009”, note the output directory and press the “Import” button. After extraction 
of the file a looping routine imports all 36 dekades. From the main ILWIS menu, select “Window” > 
“Refresh” to see the updated content of the catalogue. 
 
After the import of all 36 rainfall climatology maps (rfe_clim01_1 up to rfe_clim12_3) has been 
completed, select from the main ILWIS menu “File” > “Create” > “Map List”, as Map List name enter 
“RFE10day_clim”, select all rfe_clim_month_dekade maps (36 in total) in the left hand maplist window 
(selected maps are indicated by a blue colour), press the “>” sign to add them to the right hand Create 
MapList window and press “OK” to save the new maplist. Double click with the mouse the newly 
created Maplist “RFE10day_clim”. In the MapList window select as display option “Open as Slide 
Show”, as Representation select “rfe_dec” and press “OK” twice, add the country boundaries (no Info, 
boundaries only) and using the mouse with the left button pressed, inspect the map values. Close the 
animation window when finished. 
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Once more open the maplist “RFE10day_clim” and display the map “rfe_clim01_1”. Add to this map 
the vector layer showing the country boundaries and use the option boundaries only for display of this 
vector layer. Now from the main ILWIS menu, select “Operations” > “Statistics” > “MapList” > “MapList 
Graph”. In the maplist graph window, select as MapList “RFE10day_clim”, use a fixed stretch of “0 to 
100”, activate the options “Continuous” and “Always on top”. Activate the map window showing the 
previously opened map layer “rfe_clim01_1”. Browse with the mouse cursor over the map. Note the 
precipitation time series values in the graph window, the X-axis shows the time (from the first dekade 
of January as time step 1 to the last dekade of December as time step 36) and the Y-Axis the average 
amount of precipitation (in mm) during each 10 day period for the respective pixel. See also figure 
4.2.3. 
 

Figure 4.2.3 TAMSAT time series rainfall climatology over Africa 

 Data extraction and import automation for generation of time series precipitation data 4.2.4

In the previous exercises you have imported a variety of precipitation products using the ISOD 
Toolbox menu. You can keep using this procedure to import the other events from the same products 
by changing the Date stamp, e.g. each time selecting the next temporal interval. This is a 
cumbersome activity that needs user intervention. This procedure can be easily automated by copying 
the ILWIS command line string that is created each time you conduct an ISOD toolbox routine. 
 
From the Main ILWIS menu, press the “drop down” button on the right hand side of the command line. 
You will now see the “history”. A typical command line string that is generated when using the ISOD 
Toolbox is given below using as example the import routine used for the ‘FEWSNET 10 day RFE2’-
import (note that the command line string is given as a single line, the location of your ILWIS directory 
might be different!): 
 

!d:\Ilwis372\Extensions\ISOD-toolbox\toolbox_batchroutines\fews_rfe2_10day.bat 2010103 x x c: 
Sat_Precip d:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin d:\Ilwis372 
d:\Ilwis372\Extensions\ISOD-Toolbox\util 

 
Have a look at the command line above and note that “!” is used in ILWIS to call an external routine, in 
this case “fews_rfe2_10day.bat”. This batch file is executed for the time stamp “2010103” (for the 3rd 
dekade of October 2010). The “x” indicates that here no input drive and input directory is used. All 
other strings define the parameters that specify the locations of the required software utilities to 
conduct the operation. In your case the location of ILWIS might be in a different ‘drive:\directory’ and 
therefore your command line string might look different, but the string will have the same number of 
“items / parameters”. See also chapter 2.6 for further details. 
 
Once more execute this operation from the toolbox menu and subsequently copy this command line to 
clipboard, open ‘Notepad’ and paste the command line string as a single line into Notepad (Check 
from the Notepad menu > Format > Word Wrap off!). Delete the “!” at the start of the line and add the 
following syntax: cmd /c instead. The line now becomes: 
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cmd /c d:\Ilwis372\Extensions\ISOD-toolbox\toolbox_batchroutines\fews_rfe2_10day.bat 2010103 
x x c: Sat_Precip d:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin d:\Ilwis372 
d:\Ilwis372\Extensions\ISOD-Toolbox\util 

  
Now copy this modified line and paste it 2 more times. Modify for the 3 lines the date stamp, instead of 
“2010103”, enter as new date stamps: “2010111”, “2010112” and “2010113” respectively. Your final 
results (as 3 lines) should look like the example below: 

------------------------------------------------------------------------------------------------------------------------ 
cmd /c d:\Ilwis372\Extensions\ISOD-toolbox\toolbox_batchroutines\fews_rfe2_10day.bat 2010111 
x x c: Sat_Precip d:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin d:\Ilwis372 
d:\Ilwis372\Extensions\ISOD-Toolbox\util 

 
cmd /c d:\Ilwis372\Extensions\ISOD-toolbox\toolbox_batchroutines\fews_rfe2_10day.bat 2010112 
x x c: Sat_Precip d:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin d:\Ilwis372 
d:\Ilwis372\Extensions\ISOD-Toolbox\util 

 
cmd /c d:\Ilwis372\Extensions\ISOD-toolbox\toolbox_batchroutines\fews_rfe2_10day.bat 2010113 
x x c: Sat_Precip d:\Ilwis372\Extensions\ISOD-Toolbox\GDAL\bin d:\Ilwis372 
d:\Ilwis372\Extensions\ISOD-Toolbox\util 
------------------------------------------------------------------------------------------------------------------------ 

Save this file in your active working directory, use as file name “rfe2_nov10_import.bat”. 
 
Now use the Windows Explorer, browse to your active working directory and double click with the 
mouse on the new batch file created “rfe2_nov10_import.bat”. The RFE2 maps are now automatically 
retrieved and processed in ILWIS. When the operation has been completed, click with the mouse on 
the ILWIS catalogue and press “F5” or select from the ILWIS main menu “Window” > “Refresh”. Now 
create a maplist of the 3 imported dekadal images and show this as an animation. Also use maplist 
statistics, and the “sum” option, to calculate the monthly precipitation of November 2010. Display the 
map using as Representation “rfe_month”. Add the country boundaries (no Info, boundaries only) and 
use pixel information to inspect the values. 
 
Repeat this procedure, now prepare a batch file to import all RFE2 10 day rainfall products for 2010 
(36 events) and calculate the sum, min, max and mean yearly precipitation for 2010. 
 
Your final results (for the sum) should resemble those provided in figure 4.2.4, using a “Pseudo” 
Representation and a stretch from 0 to 1500. Note that more advanced batch procedures can be 
developed, using a so called “looping” procedure, identical to the import of the Climatology products. 
You can find various examples in the “toolbox_batchroutines” sub-directory. 
 

Figure 4.2.4: RFE2 based total precipitation over Africa for 2010 
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4.3 FEWSNET GLOBAL PET 

Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “FEWS_PET”. For the Folder items under FEWS_PET specify the 
appropriate directory and press “Save” to store the drive:\directory settings. Move to the working 
directory using the ILWIS Navigator. Close ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the “FEWSNET Global PET” > "PET 1 degree - daily 
per month" sub menu. In this case only the “Date” field and the “Output Directory” need to be 
specified. Enter a suitable date string, here as example “201104” is used to process the data from 
April 2011.  
 
Upon retrieval of the file a looping procedure is started which imports all the daily data of April 2011. 
When the import has been completed refresh the catalogue (from the main ILWIS menu, select 
“Window” and “Refresh”), open the map “pet20110401” using a “Pseudo” Representation and press 
“OK”, add the country boundaries (no Info, boundaries only) and using the mouse with the left button 
pressed inspect the map values. 
 
Select from the main ILWIS menu “File” > “Create” > “Map List”, as Map List name enter 
“PET_201104”, select all “pet_yyyymmdd” maps (30 in total) in the left hand maplist window (selected 
maps are indicated by a blue colour), press the “>” sign to add them to the right hand Create MapList 
window and press “OK” to save the new maplist. Double click with the mouse the newly created 
Maplist “PET_201104”. In the MapList window select as display option “Open as Slide Show”, as 
Representation select “Pseudo” and press “OK” twice, add the country boundaries (no Info, 
boundaries only) and using the mouse with the left button pressed inspect the map values. 
 
Eventually select from the “ISOD” > “Toolbox” main menu select the “FEWSNET Global PET” > "PET 
1 degree - daily per year" sub menu. In this case only the “Date” field and the “Output Directory” need 
to be specified. Enter a suitable Date string, here as example 2010 can used to process the data for 
the whole year of 2010. For visualization create a maplist, use a similar procedure as indicated above 
using all daily PET maps of 2010. 
 
To process a recent Global PET event, select a day during the current month.   From the “ISOD” > 
“Toolbox” main menu select the “FEWSNET Global PET” > "PET 1 degree - daily" sub menu. In this 
case the “Date” and the “Output Directory” needs to be specified. Enter a suitable date string (note 
that you can take a recent day of the current month as the full month data is not available!), here as 
example the date stamp of the day before present is used to retrieve the PET data from ‘yesterday’. 
Display the map, use as Representation “Pseudo” and press “OK”, add the country boundaries (no 
Info, boundaries only) and using the mouse with the left button pressed inspect the map values. 

4.4 FEWSNET NOAA – EMODIS NDVI  FOR AFRICA 

 FEWSNET NOAA16 and 17 derived NDVI 4.4.1

Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “FEWS_NDVI”. For the Folder item under FEWS_NDVI specify the 
appropriate directory and press “Save” to store the drive:\directory settings. Move to the working 
directory using the ILWIS Navigator. Close ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the “FEWSNET NOAA – eMODIS NDVI - Africa” > 
"NOAA NDVI (current processing suspended)" > "NDVI-N16 bulk download (NOAA-16 Calibration)" 
sub menu. In this case only the “Date” field and the “Output Directory” need to be specified. Enter a 
suitable date string, here as example “1995” is used to process the NOAA-16 derived NDVI data from 
1995. 
 
Upon retrieval of the file a looping procedure is started which imports all the dekadal NDVI data of 
1995. When the import has been completed refresh the catalogue (from the main ILWIS menu, select 
“Window” and “Refresh”), open the map “fewsndvi_950101” using a “NDVI1” Representation and 
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press “OK”, add the country boundaries (no Info, boundaries only) and using the mouse with the left 
button pressed inspect the map values. 
 
Select from the main ILWIS menu “File” > “Create” > “Map List”, as Map List name enter 
“FEWS_NDVI_1995”, select all fewsndvi__yyyymmdecdec” maps (36 in total) in the left hand maplist 
window (selected maps are indicated by a blue colour), press the “>” sign to add them to the right 
hand Create MapList window and press “OK” to save the new maplist. Double click with the mouse the 
newly created Maplist “FEWS_NDVI_1995”. In the MapList window select as display option “Open as 
Slide Show”, as Representation select “NDVI1” and press “OK” twice, add the country boundaries (no 
Info, boundaries only) and using the mouse with the left button pressed inspect the map values. 
  
In a similar manner also the "NDVI-N16 Long term mean", "NDVI-N16 Short term mean", "NDVI-N17 
bulk download (NOAA-17 Calibration)" and "NDVI-N17 Short term mean" can be retrieved and 
processed. Note that the Long Term Mean was calculated from data for the period 1982 to 2008. The 
Short Term Mean was calculated from data for the period 2004 to 2008. For NDVI-17 the Short Term 
Mean was calculated from data for the period 2003 to 2008. There is no Long Term Mean for the 
NDVI-17 product. 

 FEWSNET eMODIS derived NDVI 4.4.2

Before starting to retrieve the data first some general remarks on the conventions used for the 
eMODIS products. Recent dekadal data is available for 012010 onwards; each year is consisting of 72 
periods. Note the period’s definition: period 1 is from Dec26-Jan5 for a given year, period 2 is from 
Jan1-Jan10 for a given year, period 71 is from Dec16-Dec25 for a given year and period 72 is from 
Dec21-Dec31 for a given year. The older data, organized per month (6 files for the 6 dekades) is 
available from 2001 onwards as well as a short term mean per period (from 2001-2010). First a recent 
Temporally Smoothed NDVI, Mean Anomaly and Previous Year Difference map is going to be 
retrieved for the eastern African region. 
 
Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “FEWS_NDVI”. For the Folder item under FEWS_NDVI specify the 
appropriate directory and press “Save” to store the drive:\directory settings. Move to the working 
directory using the ILWIS Navigator. Close ILWIS and open it again. 
 
To import a recent eMODIS NDVI images, from the “ISOD” > “Toolbox” main menu select the 
“FEWSNET NOAA – eMODIS NDVI - Africa” > "eMODIS NDVI and anomaly (from 012010 - to 1 
month before present)" > "East Africa"> "Temporally Smoothed NDVI" sub menu. You can also select 
another African window. In either case only the “Date” field and the “Output Directory” needs to be 
specified. Enter a suitable Date string (per = period), here as example “022012” is used to retrieve the 
eMODIS NDVI data from the second period of 2012, from 1-10 January. Note that the whole 
procedure can take quite some time depending on your internet bandwidth as each of the four 
windows cover an extensive area and having a spatial resolution of 250 meter / pixel the files have 
considerable volume! 
 
When the import has been completed refresh the catalogue (from the main ILWIS menu, select 
“Window” and “Refresh”), open the map “emodis_ea_ndvi201202” using a “NDVI1” Representation 
and press “OK”, add the country boundaries (no Info, boundaries only) and using the mouse with the 
left button pressed inspect the map values. 
 
To import a recent eMODIS Mean Anomaly map, from the “ISOD” > “Toolbox” main menu select the 
“FEWSNET NOAA – eMODIS NDVI - Africa” > "eMODIS NDVI and anomaly (from 012010 - to 1 
month before present)" > "East Africa"> "Mean Anomaly" sub menu. You can also select another 
African window. In either case only the “Date” field and the “Output Directory” needs to be specified. 
Enter a suitable Date string (per = period), here as example also “022012” is used to retrieve the 
eMODIS Mean Anomaly NDVI data from the second period of 2012, from 1-10 January. 
 
When the import has been completed refresh the catalogue (from the main ILWIS menu, select 
“Window” and “Refresh”), open the map “emodis_ea_ndvi201202stm” using a “Pseudo” 
Representation and press “OK”, add the country boundaries (no Info, boundaries only) and using the 
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mouse with the left button pressed inspect the map values. Note that the anomalies represent a 
subtraction of the mean NDVI values (2001-2010) for a given 10-day period from current-year values 
for the same period, rendering an image where negative values portray less vigorous vegetation than 
average, and positive values represent areas that are more vigorous in the current year. 
 
To import a recent eMODIS Previous Year Difference, from the “ISOD” > “Toolbox” main menu select 
the “FEWSNET NOAA – eMODIS NDVI - Africa” > "eMODIS NDVI and anomaly (from 012010 - to 1 
month before present)" > "East Africa" > "Previous Year Difference" sub menu. You can also select 
another African window. In either case only the “Date” field and the “Output Directory” needs to be 
specified. Enter a suitable Date string (per = period), here as example also “022012” is used to 
retrieve the eMODIS Previous Year Difference. 
 
When the import has been completed refresh the catalogue (from the main ILWIS menu, select 
“Window” and “Refresh”), open the map “emodis_ea_ndvi201202dif” using a “Pseudo” Representation 
and press “OK”, add the country boundaries (no Info, boundaries only) and using the mouse with the 
left button pressed inspect the positive and negative map values. 
 
To import historical eMODIS NDVI images, from the “ISOD” > “Toolbox” main menu select the 
“FEWSNET NOAA – eMODIS NDVI - Africa” > "eMODIS NDVI historical data (2001-2011)" > "East 
Africa"> "Monthly NDVI" sub menu. You can also select another African window. In either case only 
the “Date” field and the “Output Directory” needs to be specified. Enter a suitable Date string (m = 
month), here as example “022001” is used to retrieve the eMODIS historical NDVI data from February 
2001. Note that the whole procedure can take quite some time depending on your internet bandwidth 
as each of the four windows cover an extensive area and having a spatial resolution of 250 meter / 
pixel the files have considerable volume! Furthermore 6 files per month are being processed, covering 
the dekades defined by the eMODIS team. Note once more that the even periods are from 01-10, 11-
20 and 21 till the end of the month. The odd periods are from 26 of the previous month to 5 (of the 
current month), 6-15 and 16-25, etc. 
 
Upon retrieval of the file a looping procedure is started which imports all the dekadal NDVI data of the 
selected month. When the import has been completed refresh the catalogue (from the main ILWIS 
menu, select “Window” and “Refresh”), open the map “emodis_ea_ndvi0801” using a “NDVI1” 
Representation and press “OK”, add the country boundaries (no Info, boundaries only) and using the 
mouse with the left button pressed inspect the map values. Note that period 08 represents the data 
from 01-10 February 2001! 
 
To import the short term mean eMODIS NDVI images, from the “ISOD” > “Toolbox” main menu select 
the “FEWSNET NOAA – eMODIS NDVI - Africa” > "eMODIS NDVI historical data (2001-2011)" > 
"East Africa"> "East Africa"> "Short Term Mean NDVI" sub menu. You can also select another African 
window. In either case only the “Date” field and the “Output Directory” needs to be specified. Enter a 
suitable Date string (m = month), here as example “02” is used to retrieve the eMODIS Short Term 
Mean NDVI data for February. 
 
Upon retrieval of the file a looping procedure is started which imports all the short term mean NDVI 
data of the selected month. When the import has been completed refresh the catalogue (from the 
main ILWIS menu, select “Window” and “Refresh”), open the map “emodis_ea_stm08” using a 
“NDVI1” Representation and press “OK”, add the country boundaries (no Info, boundaries only) and 
using the mouse with the left button pressed inspect the map values. Note that period 08 represents 
the short term mean of 01-10 February! The short term mean is currently derived for NDVI data for the 
period 2001-2010. The retrieved short term mean NDVI is presented in figure 4.4.1. 
 



52 

 

Figure 4.4.1. eMODIS short term mean for 01-10 February 

 

4.5 GLOBAL ELEVATION DATA 

 GMTED 2010 4.5.1

Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “DEM”. For the Folder items under GMTED_DEM, SRTM_DEM and 
ASTER_DEM specify the appropriate directory and press “Save” to store the drive:\directory settings. 
Note that for the ASTER_DEM folder settings also a local input directory has to be specified. Also 
create this temporary directory. Move to the new working directory using the ILWIS Navigator. Close 
ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the “Global Elevation Data”, “GMTED2010” > “GMTED 
30 Arc Sec / 1 km" sub menu. In this case the Lower Left Latitude and Longitude Corner coordinates 
have to be specified. Note that the Latitude interval is 20 degrees (from N90 to S70) and the longitude 
interval is 30 degrees (from W180 to E150) Enter a suitable lower left corner coordinate pair; N, S, W 
and E are case sensitive, enter them as capital. In this example for Lat: “N30” and Long: “E000” are 
used. Check the output folder and press “Import”. 
 
After the import has been completed, display the new map created: “gmted300_N30E000”, use as 
Representation “Elevation3”, add the country boundaries (no Info, boundaries only) and using the 
mouse with the left button pressed inspect the map values. Do not close the map windows at this 
moment. 
 
In ILWIS a whole suite of DEM processing routines are available. Open from the Operation-Tree, the 
tab “DEM hydro-processing” > “Dem Visualization”. As input DEM select the newly imported elevation 
model, here “gmted300_N30E000” is used. The default Output Map name can be used and press 
“OK”. Further information on these routines is provided under the ILWIS Help function. Close the map 
“colshadow”. Now add the newly created map “colshadow” to the map window of the 
“gmted300_N30E000”. To do this, select from the active map window displaying the map 
“gmted300_N30E000” the option “Layers” > “Add Layer”, select the map “colshadow” and press “OK”. 
Select the “colshadow” map from the left hand legend menu of the active map display window and 
drag the map below the map “gmted300_N30E000”. Double click the map layer “gmted300_N30E000” 
and from the Map Display options menu activate the option “Transparent”, set the transparency to 50 
% and press “OK”. From the active map display window, select from the menu “Options” > “No Zoom”. 
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Use the “Pan” Function to scroll over the map window. Your results should resemble those given in 
figure 4.5.1. Close the map when finished. 
 
In an identical manner the “GMTED 15 Arc Sec / 500 m” and “GMTED 7.5 Arc Sec / 250 m” can be 
retrieved and processed. Note that due to the increased spatial resolution the file sizes increase. Note 
that the output file name is indicating the spatial resolution selected, e.g. “gmted150_*” and 
“gmted075_*”. 
 

Figure 4.5.1. GMTED 30 Arc Seconds visualization 

 

 SRTM Version 4 4.5.2

From the “ISOD” > “Toolbox” main menu select the “Global Elevation Data” > “SRTM Version 4” > 
“SRTM 3 Arc Sec / 90 m 5 X 5 degree tiles” sub menu. In this case Lower Left Latitude and Longitude 
Corner coordinates have to be specified. Note that the Latitude interval is 5 degrees (up to 60 degrees 
north and south) and the longitude interval is also 5 degrees (from W180 to E180) Enter a suitable 
lower left corner coordinate pair; N, S, W and E are case sensitive, enter them as capital. In this 
example for Lat: “S20” and Long: “E010” are used. Check the output folder and press “Import”. 
  
Note that the coordinate pair used is transformed into the corresponding SRTM tile index number. The 
GeoTIFF file is retrieved from the selected FTP location and converted into an ILWIS format. Note that 
in the batch file additional locations for retrieval are given.  
 
After the import has been completed, display the new map created: “srtm_S20E010”, use as 
Representation “Elevation3”, add the country boundaries (no Info, boundaries only) and using the 
mouse with the left button pressed inspect the map values. You can use the DEM hydro-processing 
tools to further process the elevation model. Note that if you want to combine multiple tiles you can 
use the generic ILWIS option “GlueRas”, available from the main ILWIS menu under “Operations” > 
“Raster Operations” > “Glue Maps”. 

 ASTER GDEM Version 2 4.5.3

One has to register to get access to the GDEM data. Therefore the import routine can’t automatically 
retrieve the data. Eventually register and login to obtain the GDEM data (from: 
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http://www.gdem.aster.ersdac.or.jp/). Select the required elevation data and download it first onto a 
local storage device in the temporary directory created.  
 
Once the selected elevation information is downloaded open from the “ISOD” > “Toolbox” main menu 
select the “Global Elevation Data” > “ASTER GDEM Verion 2” > “ASTER GDEM 1 Arc Sec / 30 m 1 X 
1 degree tiles” sub menu. In this case Lower Left Latitude and Longitude Corner coordinates have to 
be specified. Note that the Latitude interval is 1 degree (up to 83 degrees north and south) and the 
longitude interval is also 1 degree (from W180 to E180). Enter a suitable lower left corner coordinate 
pair; N, S, W and E are case sensitive, enter them as capital. In this example the file 
“ASTGTM2_S02E030” was manually downloaded and stored into the input folder specified under the 
“Configuration” and “Folders” options of the ISOD Toolbox main menu. Now the following coordinates 
are applied in the import window: for Lat: “S02” and Long: “E030”. Check the output folder and press 
“Import”. 
 
After the import has been completed, display the new map created: “ASTGTM2_S02E030”, use as 
Representation “Elevation3” and using the mouse with the left button pressed inspect the map values. 
You can use the DEM hydro-processing tools to further process the elevation model. Note that if you 
want to combine multiple tiles you can use the generic ILWIS option “GlueRas”, available from the 
main ILWIS menu under “Operations” > “Raster Operations” > “Glue Maps”. Your results should 
resemble those of figure 4.5.2, using the option “No Zoom” available from the active map display 
window menu “Options”.   

 
Figure 4.5.2. ASTER GDEM S02E030 

 
 

4.6 MEASURES GLOBAL VI PRODUCTS V2 

Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “VIP”. For the Folder item under “Global_VI” specify the appropriate 
directory and press “Save” to store the drive:\directory settings. Move to the working directory using 
the ILWIS Navigator. Close ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the "MEaSUREs Global VI Products V2" > "Global 
Vegetation Indices" > "Daily NDVI-EVI2" sub menu. Note that the routine expects a year – Julian date 
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input, e.g. specify for 31 January 2010 the following time stamp: “2010031”. Check the output folder 
and press “Import”. 
 
After the import has been completed (can take some time as these are large files), display the new 
map created: “VIP01NDVI_2010031”, use as Representation “NDVI1” and press “OK”, add the country 
boundaries (no Info, boundaries only) and using the mouse with the left button pressed inspect the 
map values.  Also display the map “VIP01EVI2_2010031” and use as Representation “NDVI1” and 
press “OK”. Here VIP01 indicates that this is the daily product. 
 
You can repeat the procedure and import the 7-day, 15-day or monthly NDVI-EVI2 products. Note that 
to obtain the appropriate date stamp, for the 7-day product use a multiple of 7 + 1, e.g. for the second 
week of January 2010, use as Date stamp: “2010015. Use an identical procedure to get the 15-day or 
monthly product (multiple of 15 + 1 or multiple of days of month + 1). Take normal or leap year 
occurrence into consideration! Note that the output file names start with the temporal interval selected, 
like VIP07, VIP15, VIP30, for 7-days, 15-days and monthly temporal resolution respectively. When 
displaying the retrieved maps, use as Representation “NDVI1”, add the country boundaries (no Info, 
boundaries only) and using the mouse with the left button pressed inspect the map values. 

4.7 NASA GLOBAL OCEAN DATA 

Open the “ISOD” > “Toolbox” options from the left hand menu tree and open the item “Configuration” > 
“Folders”. Note that here the assumption is made that you have created on your local system, using 
drive “C”, a directory called “Ocean”. For the Folder item under “NASA_Ocean” specify the appropriate 
directory and press “Save” to store the drive:\directory settings. Move to the working directory using 
the ILWIS Navigator. Close ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the options "NASA Global Ocean Data" > "Ocean 
SST" > "ModisT-SST daily". Note that the routine expects a year – Julian date input, e.g. specify for 31 
January 2010 the following time stamp: “2010031”. Check the output folder and press “Import”. 
 
After the import has been completed display the new map created: “sst_T2010031”, use as 
Representation “sst” and press “OK”, add the country boundaries (no Info, boundaries only) and using 
the mouse with the left button pressed inspect the map values for example along the coast of Namibia. 
Note the unit is in degree Celsius.   
 
From the “ISOD” > “Toolbox” main menu select the options "NASA Global Ocean Data" > "Ocean 
SST" > "ModisT-NSST daily". Note that the routine expects a year – Julian date input, e.g. specify for 
31 January 2010 the following time stamp: “2010031”. Check the output folder and press “Import”. 
 
After the import has been completed display the new map created: “nsst_T2010031”, use as 
Representation “sst” and press “OK”, add the country boundaries (no Info, boundaries only) and using 
the mouse with the left button pressed inspect the map values.   
 
From the “ISOD” > “Toolbox” main menu select the options "NASA Global Ocean Data" > "Ocean 
Chlor-A" > "ModisT-Chlor-A daily". Note that the routine expects a year – Julian date input, e.g. 
specify for 31 January 2010 the following time stamp: “2010031”. Check the output folder and press 
“Import”. 
 
After the import has been completed display the new map created: “chlorA_T2010031”, use as 
Representation “Pseudo” and press “OK”, add the country boundaries (no Info, boundaries only) and 
using the mouse with the left button pressed inspect the map values (unit in mg m-3).   
 
In a similar manner also the products derived from the MODIS Aqua sensor can be retrieved and 
processed. 

4.8 GLOBAL LAND DATA ASSIMILATION SYSTEM 

To retrieve soil moisture products open the “ISOD” > “Toolbox” options from the left hand menu tree 
and open the item “Configuration” > “Folders”. Note that here the assumption is made that you have 
created on your local system, using drive “C”, a directory called “SSM”. For the Folder item under 
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“GLDAS” specify the appropriate directory and press “Save” to store the drive:\directory settings. Move 
to the working directory using the ILWIS Navigator. Close ILWIS and open it again. 
 
From the “ISOD” > “Toolbox” main menu select the options "Global Land Data Assimilation System" > 
"Hydrology" > "Day time LPRM TMI/TRMM SSM and Skin Temperature". Enter a suitable Date string, 
here as example “20120425” is used. Check the output folder and press “Import”. 
 
After the import has been completed two new maps have been created, first display the map created: 
“LPRM_TMI_day_sm_x20120425”, use as Representation “Pseudo” and press “OK”, add the country 
boundaries (no Info, boundaries only) and using the mouse with the left button pressed inspect the 
map values. 
 
Display also the map “LPRM_TMI_day_ts20120425” use as Representation “Pseudo” and press “OK”, 
add the country boundaries (no Info, boundaries only) and using the mouse with the left button 
pressed inspect the map values. 
 
From the “ISOD” > “Toolbox” main menu select the options "Global Land Data Assimilation System" > 
"Hydrology" > "Night time LPRM TMI/TRMM SSM and Skin Temperature" and use the same date 
stamp. Display both the retrieved “night_sm” and “night_ts” products using as Representation 
“Pseudo” and press “OK”, add the country boundaries (no Info, boundaries only) and using the mouse 
with the left button pressed inspect the map values. 
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4.10 WEB MAPPING SERVICES 

 Introduction 4.10.1

In the toolbox a number of routines have been included to retrieve information from various online 
resources that are currently not converted into an ILWIS data format, but use is made of the files as 
retrieved and these are visualized using IrfanView and Panoply. Open the “ISOD” > “Toolbox” options 
from the left hand menu tree and open the item “Configuration” > “Folders”. Note that here the 
assumption is made that you have created on your local system, using drive “C”, a directory called 
“WMS”. For the Folder items under CPC_SST, ECMWF, ITCZ, MET_UK, MPE2Google, NOAA_chart 
and RFS2Google specify the appropriate directory and press “Save” to store the drive:\directory 
settings. Note that for the visualization use is made of IrfanView, Also check under the Folder item 
“Special locations” if the location to “iview*.exe” is properly specified. Move to the new working 
directory using the ILWIS Navigator. Close ILWIS and open it again. 

 MPE and RFS to Google 4.10.2

These two services make use of the 15 minutes precipitation products, the MPE derived from MSG 
and the RFS derived from GOES. At ITC these 15 minutes products are aggregated to obtain the 24 
hour precipitation amount in mm (from 00:00 to 23:45 UTC). These files are compressed and 
subsequently transferred to a FTP site (ftp://ftp.itc.nl/pub/mpe/). After specifying an output directory 
the application can be started, the accumulated 24 hour precipitation map is downloaded, 
decompressed and transformed into a PNG format (with a transparent layer for the areas that have 
not received precipitation). A “KML” file is created and executed which invokes Google Earth to start 
and display the results. These applications assume that Google Earth is locally available.  
 
From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services”, “MPE to Google” > 
“Aggregated 24 hour MPE to Google Earth” sub menu. In this case only the “Date” field and the 
“Output Directory” need to be specified. Enter a suitable date, e.g. “20111101” to extract the 24 hour 
aggregated Multi Sensor Precipitation Estimate from the ITC-FTP site and press “Import”. Note that in 
order to produce this map, 96 events over a 24 hour period have been processed, and you extract the 
sum of all these 15 minutes events. The unit is in mm / 24 hours, from 00:00 to 23:45 UTC for a given 
day. During UTC noon the precipitation map of the previous day is available from this FTP site. The 
map is shown in Google Earth and after inspection the application is closed. The original data (in 
ILWIS format) is not deleted and can be displayed using ILWIS (having as file name 
“fsummsgmpeyyymmdd”), using as Representation “mpe_sum”. Display also this map using ILWIS 
and add the country boundaries (no Info, boundaries only) and check the map values. 
 
Also select the option “Web Mapping Services” > “RFS to Google” > “Aggregated 24 hour RFS to 
Google Earth”, note the output directory and specify an appropriate Date stamp, e.g. “20111101” and 
press “Import”. The unit is in mm / 24 hrs, from 00:00 to 23:45 UTC for a given day. During UTC noon 
the precipitation map of the previous day is available from this FTP site. The map is shown and then 
the Google Earth application can be closed. The original data (in ILWIS format) is not deleted and can 
be displayed (having as file name “fsumrfsyyymmdd”), using as Representation “mpe_sum”. Display 
also this map using ILWIS and add the country boundaries (no Info, boundaries only) and check the 
map values. 

 Surface Pressure Forecast Europe 4.10.3

Once more, before you start this routine check under the options “Configuration” > “Folders” > “Special 
locations” if the IrfanView directory and “i_view” executable is correctly specified, see also chapter 2.4. 
In the “Configuration” > “Folders” subsequently select “MET_UK”. Ensure that the drive:\output 
directory settings are correctly specified as well. Use the ILWIS navigator to move to the 
drive:\directory specified. 
 
From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services”, “Surface Pressure 
Forecast Europe” > "UK MET Office surface pressure (T+0) to 84-hour (T+84) forecast", note the 
output drive:\directory and press “Import”. An animation is showing the pressure forecast.  
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Note that if the slide advancement is not appropriate; open an instance of IrfanView yourself. From the 
menu select “File” > “Slideshow”. Modify the timing of the “Slide advancement”, specify for “Automatic 
after” “1.00” seconds and activate the option “Play in full screen mode (current monitor)”. Close 
IrfanView and start the retrieval procedure once more. You can also modify other settings in IrfanVIew 
according to your preferences. For further assistance using IrfanView consult the “Help” function from 
the menu of the  software. 

 Current Position of the Africa ITF 4.10.4

From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services”, “Current Position of the 
Africa ITF" > "Latest Current Position of the ITF-ITCZ (NOAA)" and press “Import”. To terminate the 
image visualization press <Escape>. Note that only the current ITCZ dekadal image is given when it is 
situated over the Northern Hemisphere! 

 NOAA Weather Charts 4.10.5

From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services”, “NOAA Weather Charts" 
and select your region of interest, here "Europe-Africa" is used as example. Select “NWS forecast for 
FL050 (5000 ft, using int. pressure datum of 1013.25 hPa)” and press “Import”. After retrieval of the 
files an animation is repeated a couple of times, note the change of the time stamp of the forecast. For 
details on the Flight Level used and image symbols consult also chapter 3.10.1. 

 NOAA-CPC SST and SST Anomaly 4.10.6

Before you start this routine first check under the options “Configuration” > “Folders” > “Special 
locations” if the IrfanView directory and “i_view” executable is correctly specified, see also chapter 2.4. 
In the “Configuration” > “Folders” subsequently select “CPC_SST”. Ensure that the drive:\output 
directory settings are correctly specified as well. Use the ILWIS navigator to move to the 
drive:\directory specified. 
 
From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services” > "NOAA-CPC SST-SST 
Anomaly" > "Latest 12 weeks SST and Anomaly animation" and press “Import”. After retrieval of the 
files the SST and anomaly animation shown. You can stop the animation by pressing the <Esc> 
button of your keyboard. Note the change of the weekly time stamp of the SST and Anomaly in the 
animation (12 weeks before present). 

 ECMWF Re-Analysis 4.10.7

Before you start this routine first check under the options “Configuration” > “Folders” and subsequently 
select “ECMWF”. Ensure that the drive:\output directory settings are correctly specified. Use the ILWIS 
navigator to move to the drive:\directory specified. Note that this option is making use of the Panoply 
utility for visualization of the downloaded data. Check the description in chapter 1.5 if you have 
correctly installed “Panoply” (the “Panoply.exe” and associated sub-directories should be available in 
root of the ILWIS sub-directory “\Extensions\ISOD-Toolbox\util\Panoply”). 
 
This routine expects that the data is locally available, retrieved in NetCDF format. Before you start the 
routine first download manually the data which you want to visualize from http://data-
portal.ecmwf.int/data/d/interim_daily/. Here as an example the data for the month of “June 2012”, 
Time: “12:00:00”, Step: “12” and Parameter: “Sunshine Duration” is selected and downloaded. The file 
(“output.nc”) is stored locally in the specified working directory.  
  
From the “ISOD” > “Toolbox” main menu select the “Web Mapping Services” > "ECMWF Re-Analysis 
data" > "Show ERA Interim Daily Fields" and press “Import”. After acknowledgement of the copyright 
press “<enter>” to start the application. After Panoply has started, browse to your working directory 
and select the file “output.nc” and press “Open”. Double click on the layer “sund”, select as Plot type 
“Lon-Lat” to see the resulting Sunshine Duration global plot of “2012-06-02 00:00”. From the menu you 
can always consult the “Help” function to get further information on the functionality of this utility. You 
can close the application when finished inspecting the data. 
 



59 

 

5. CONCLUSIONS 

This manual is mainly focussing on data retrieval and visualization of the various free environmental 
data sources residing on the internet. Other documents demonstrating how to further process the data 
can be found under the links indicated in appendix 2.  
 
Various environmental data resources, especially time series of data, are currently freely available 
through the internet but the potential User Community is likely not aware of its existence. The “In Situ 
and Online Data Toolbox” (ISOD) is therefore developed to easily ingest these data sources. To 
operate the toolbox, internet connectivity is required. Some of the data sources are having high data 
volumes and therefore a reasonable bandwidth is required to smoothly operate some of the toolbox 
routines, especially for import of time series data. 
 
The archived time series of data supplement the near real-time data currently disseminated through 
telecommunication based data dissemination systems like GEONETCast. It is hoped that when using 
the toolbox routines developed the various data sources are used for appropriate assessment of the 
environment. Currently a focus was given to global data sets and data provision for Africa. If toolbox 
users have links to other resources they would like to have included in a next version of the ISOD 
toolbox contact the EO-Community Contact at: http://52north.org/communities/earth-observation/ 
community-contact. This link can also be used if other remarks or comments do arise.  
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APPENDICES 

Appendix 1: Other utilities available at the EO Community web pages at 52North.org 

Various other software utilities have been developed over time are released via the 52North.org web 
portal, through the Earth Observation Community, available at: http://52north.org/communities/earth-
observation/overview. A short overview of the freely available ILWIS plug-ins is presented below. Also 
dedicated ILWIS scripts are available to import the Culture MERIS and METOP AVHRR-S10 data 
(under data bases) as well as various documents and useful links. 
 
 
 

ILWIS plug-ins to handle free Environmental data sources 
 

 

 
 

 
 

 
 
 
 
 
 
 
 
 
  

Current data dissemination systems, like 
GEONETCast and the ESA DDS provide free, 
near real-time Environmental and Earth 
Observation data together with derived 
products to a worldwide user community. The 
environmental data is delivered on a global 
scale via communication satellites. Next to 
this, a multitude of environmental relevant 
data is residing in online archives. To integrate 
this information toolbox plug-ins have been 
developed, also dealing with specific geogra-
phic regions only upon user request, like the 
AMESD-SADC Toolbox and the Water and Food 
Security Toolbox for Ethiopia (which is under 
development). 
 
The toolbox plug-ins, coupled with the existing 
ILWIS processing utilities, facilitate easy 
integration of large amounts of environmental 
data into various applications related to 
weather, atmosphere, oceans, land, vegeta-
tion, water and environment.  
 

General Key Features: 
 open design and easy user configuration  
 GEONETCast and ESA-DDS data management system for 

dedicated storage of data 
Features GEONETCast Toolbox Version 1.3 

 import routines for various satellites, Meteorological Product 
Extraction facility (MPEF), Satellite Application Facilities 
(SAF’s), Chinese Meteorological Administration and 3rd party 
data providers such as TAMSAT, DevCoCast, MODIS, SPOT 
Vegetation 

 integration of METOP-AVHRR and JASON-2 data 
 export routines to BILKO and R 
 calculation of solar and MSG zenith and azimuth angles 
 real time METEOSAT Second Generation visualization 

Features Water and Food Security–Ethiopia Toolbox Version 1.0 
 processing selected GEONETCast data relevant for water and 

food security monitoring and analysis for Ethiopia, including 
Meteorological Data Dissemination Service routines 

Features ISOD Toolbox Version 1.1 
 retrieval and import of data from various free online archives 

related to in situ climatological observations, gauge and 
satellite derived rainfall estimates, weather and pressure 
forecasts, potential evapotranspiration, normalized difference 
vegetation indices, ocean and elevation information 

Features AMESD-SADC Toolbox Version 1.2 
 import and pre-processing of all products disseminated by the 

AMESD-SADC program for southern Africa, related to 
agriculture, drought and fire 
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Appendix 2: Utilities available at the ITC GEONETCast web pages 

For access to the Capacity Building utilities use can be made of the information and documents 
posted on: http://www.itc.nl/Pub/WRS/WRS-GEONETCast. Various documents are presented here 
providing further information on data dissemination systems providing a multitude of free 
environmental information, without the need for internet access but using a local ground receiving 
station for reception of the data. 
 
For more advanced use of the environmental information in ILWIS use can be made of the so-called 
“GEONETCast-DevCoCast Application manual”, providing various exercises, including description, 
exercise data and powerpoint presentation. Also other training materials are available from the ILWIS 
community at http://52North.org as well as from http://www.itc.nl/ilwis/downloads/ilwis33.asp, check 
the left hand “Documentation” and “Applications” tabs. 
 
Also a Moodle based Capacity Building portal, the “Earth Observation Capacity Building Portal” is 
under construction, providing a lot course materials provided during various workshops conducted. 
The link to this resource is http://130.89.212.208:100/. It requires a password; you can contact the 
corresponding author for access. 
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Appendix 2: Changelog   

ISOD Toolbox version 1.1 

The ISOD toolbox v1.1 menu structure has been modified substantially and a number of new data 
retrieval – import routines have been added. The menu structure, also due to the addition of routines, 
required modification. The Web Mapping Services now focus on retrieval of data sets that are not 
imported into an ILWIS data format, the data is visualized using IrfanView of Panoply. All other 
routines extract (multi-temporal) data which is subsequently transformed into an ILWIS data format for 
further analysis. Next to this for all routines first a check is done if the data is available from the 
archives, if this is not the case the user is informed about the missing data and can abort the import 
procedure. The Installation and User Guide has been updated to reflect the changes incorporated. 

Changes 

In the XML version 1.1 of the ISOD toolbox various changes have been implemented. The most 
important are: 

Modification of the menu, the web mapping services are now retrieving the data and do not convert 
these into ILWIS data format, the data is visualized using IrfanView and Panoply 

All routines have been checked and in case data sources have been modified (e.g. re-processed) or if 
links to these data sources have changed the import routines have been adapted. Some bugs in 
import routines have been corrected. 

All routines now first check if data is downloaded before further processing is done, if no data can be 
retrieved the routine can be aborted. 

New routines have been added, like retrieval of: 

TRMM 3B42 global daily rainfall archive; 

MEaSUREs Global Vegetation Products (NDVI and Enhanced Vegetation Index) for various 
data integration periods, like daily, 7-days, 15-days and monthly time intervals; 

NASA Global Ocean Data (day and night time SST and Chlorophyl-a from MODIS Terra and 
Aqua); 

Daily Surface Soil Moisture from TRMM-TMI (day and night time overpasses) from the Global 
Land Data Assimilation System; 

Web Mapping Services, added visualization of data from the ECMWF (using Panoply) and 
NOAA-CPC SST and SST anomaly animations. 
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